summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Snowhill2020-12-06 02:05:12 -0800
committerChristopher Snowhill2020-12-06 02:05:12 -0800
commitf4407383061bcc83edd8cac51f32c6d9f402f19b (patch)
tree562321c0e0e2c2c69efec62da2650cecbaacf022
parenta40b52daab5f23caf0fb874b446652e3b2bd868b (diff)
downloadaur-f4407383061bcc83edd8cac51f32c6d9f402f19b.tar.gz
Update to 0.3.17. Disable bluez5, as client libraries probably don't need it anyway. Plus, the new libldac and libopenaptx dependencies don't have lib32 versions in the AUR yet, so I'd have to make those first.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a04523e13fd..a3f7ed6ef860 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-pipewire
pkgdesc = Server and user space API to deal with multimedia pipelines (32-bit client libraries)
- pkgver = 0.3.16
+ pkgver = 0.3.17
pkgrel = 1
url = https://pipewire.org
arch = x86_64
@@ -18,16 +18,14 @@ pkgbase = lib32-pipewire
makedepends = lib32-vulkan-icd-loader
makedepends = lib32-dbus
makedepends = lib32-libsndfile
- makedepends = lib32-bluez-libs
makedepends = vulkan-headers
- source = git+https://github.com/PipeWire/pipewire#commit=09d373f094f0e6797aef3d97cde2c0167dccc986
+ source = git+https://github.com/PipeWire/pipewire#commit=f5f5beb0ece64c7d08edb5413dde537ec5b6c3e2
sha256sums = SKIP
pkgname = lib32-pipewire
depends = lib32-sbc
depends = rtkit
depends = lib32-vulkan-icd-loader
- depends = lib32-bluez-libs
depends = alsa-card-profiles
depends = lib32-dbus
depends = lib32-libsndfile
@@ -39,11 +37,11 @@ pkgname = lib32-pipewire
pkgname = lib32-pipewire-jack
pkgdesc = Server and user space API to deal with multimedia pipelines (32-bit client libraries) (JACK support)
- depends = lib32-pipewire=0.3.16
+ depends = lib32-pipewire=0.3.17
depends = lib32-jack2
pkgname = lib32-gst-plugin-pipewire
pkgdesc = Multimedia graph framework - pipewire plugin (32-bit version)
- depends = lib32-pipewire=0.3.16
+ depends = lib32-pipewire=0.3.17
depends = lib32-gst-plugins-base-libs
diff --git a/PKGBUILD b/PKGBUILD
index 2a34bcb566c0..300b0279506f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgbase=lib32-pipewire
_pkgbase=pipewire
pkgname=(lib32-pipewire lib32-pipewire-jack lib32-gst-plugin-pipewire)
-pkgver=0.3.16
+pkgver=0.3.17
pkgrel=1
pkgdesc="Server and user space API to deal with multimedia pipelines (32-bit client libraries)"
url="https://pipewire.org"
@@ -13,9 +13,9 @@ license=(LGPL2.1)
arch=(x86_64)
makedepends=(git meson valgrind lib32-jack2 lib32-libpulse lib32-alsa-lib
lib32-gstreamer lib32-gst-plugins-base lib32-sbc rtkit
- lib32-vulkan-icd-loader lib32-dbus lib32-libsndfile lib32-bluez-libs
+ lib32-vulkan-icd-loader lib32-dbus lib32-libsndfile
vulkan-headers)
-_commit=09d373f094f0e6797aef3d97cde2c0167dccc986 # tags/0.3.16
+_commit=f5f5beb0ece64c7d08edb5413dde537ec5b6c3e2 # tags/0.3.17
source=("git+https://github.com/PipeWire/pipewire#commit=$_commit")
sha256sums=('SKIP')
@@ -40,6 +40,7 @@ build() {
--libdir /usr/lib32 \
-D docs=false \
-D tests=false \
+ -D bluez5=false \
-D udevrulesdir=/usr/lib/udev/rules.d
meson compile -C build
}
@@ -62,9 +63,9 @@ _ver=${pkgver:0:3}
_spaver="0.2"
package_lib32-pipewire() {
- depends=(lib32-sbc rtkit lib32-vulkan-icd-loader lib32-bluez-libs
- alsa-card-profiles lib32-dbus lib32-libsndfile lib32-libudev0-shim
- lib32-alsa-lib lib32-systemd lib32-glib2)
+ depends=(lib32-sbc rtkit lib32-vulkan-icd-loader alsa-card-profiles
+ lib32-dbus lib32-libsndfile lib32-libudev0-shim lib32-alsa-lib
+ lib32-systemd lib32-glib2)
optdepends=('lib32-pipewire-jack: JACK support')
DESTDIR="$srcdir/install" meson install -C build