summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Bezerra2023-12-19 10:20:13 -0300
committerRodrigo Bezerra2023-12-19 10:20:13 -0300
commitec47722cd71d222fe3ccfd61eb3a60dfc9aa1fa1 (patch)
tree849d518c3873ddb402a0b8b879eda1263a91bb70
parent78dc0db77ec30e02ac2af27cd69dcb35175fb470 (diff)
downloadaur-lib32-raptor.tar.gz
Add patch for libxml2
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
-rw-r--r--raptor-2.0.15-libxml2-2.11.patch30
3 files changed, 43 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f3eb8abf3b5..02b5d7af98f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-raptor
pkgdesc = A C library that parses RDF/XML/N-Triples into RDF triples (32 bit)
pkgver = 2.0.16
- pkgrel = 1
+ pkgrel = 2
url = https://librdf.org/raptor
arch = x86_64
license = Apache
@@ -19,10 +19,13 @@ pkgbase = lib32-raptor
depends = raptor
source = https://librdf.org/dist/source/raptor2-2.0.16.tar.gz
source = https://librdf.org/dist/source/raptor2-2.0.16.tar.gz.asc
+ source = raptor-2.0.15-libxml2-2.11.patch
validpgpkeys = F879F0DEDA780198DD08DC6443EC92504F71955A
sha512sums = 9bd5cff36390e1e0ef15ac56e5413ecfceb4018cb531a4da8850d3623615f12a93690a78be61f9d9ae7a24e16f6446e356bc2b7f34051ddc077761d85a9b7c44
sha512sums = SKIP
+ sha512sums = 6d6c6ab0be9136ccf3e5b0c1140e88a49cbf94d4c36d27e3bb672ef13c83cdc7c8048c7ef883f9302fb3924ed78db1b059a983b9e1f8bce4522d5ef33a811ba7
b2sums = 1e5e5742ba4cdaacb98a9ba77a9352589df0da60869e7721ee140c81ed4886bf909b37b247bd925c82a4ac44b3c11a909c913f0851d49a1d9d91c9293189266d
b2sums = SKIP
+ b2sums = 0e3462817a77917eb82066f7d9efb1a28fa27221596c18fb140dadb4c0fd074b0936ed5cbd9fc620548796f548ad75890b00a3f73300af7d754cea695dc7f993
pkgname = lib32-raptor
diff --git a/PKGBUILD b/PKGBUILD
index 5a04ed79a7f4..421672088e30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,23 +5,28 @@
_name=raptor2
pkgname=lib32-raptor
pkgver=2.0.16
-pkgrel=1
+pkgrel=2
pkgdesc="A C library that parses RDF/XML/N-Triples into RDF triples (32 bit)"
arch=(x86_64)
url="https://librdf.org/raptor"
license=(Apache GPL2 LGPL2.1)
depends=(lib32-glibc lib32-libxml2 lib32-libxslt lib32-xz lib32-zlib raptor)
makedepends=(gcc-multilib gtk-doc lib32-curl lib32-icu)
-source=(https://librdf.org/dist/source/$_name-$pkgver.tar.gz{,.asc})
+source=(https://librdf.org/dist/source/$_name-$pkgver.tar.gz{,.asc}
+ raptor-2.0.15-libxml2-2.11.patch)
sha512sums=('9bd5cff36390e1e0ef15ac56e5413ecfceb4018cb531a4da8850d3623615f12a93690a78be61f9d9ae7a24e16f6446e356bc2b7f34051ddc077761d85a9b7c44'
- 'SKIP')
+ 'SKIP'
+ '6d6c6ab0be9136ccf3e5b0c1140e88a49cbf94d4c36d27e3bb672ef13c83cdc7c8048c7ef883f9302fb3924ed78db1b059a983b9e1f8bce4522d5ef33a811ba7')
b2sums=('1e5e5742ba4cdaacb98a9ba77a9352589df0da60869e7721ee140c81ed4886bf909b37b247bd925c82a4ac44b3c11a909c913f0851d49a1d9d91c9293189266d'
- 'SKIP')
+ 'SKIP'
+ '0e3462817a77917eb82066f7d9efb1a28fa27221596c18fb140dadb4c0fd074b0936ed5cbd9fc620548796f548ad75890b00a3f73300af7d754cea695dc7f993')
validpgpkeys=('F879F0DEDA780198DD08DC6443EC92504F71955A') # Dave Beckett <dave@dajobe.org>
prepare() {
cd $_name-$pkgver
+ patch -Np1 -i ../raptor-2.0.15-libxml2-2.11.patch
+
autoreconf -fiv
}
diff --git a/raptor-2.0.15-libxml2-2.11.patch b/raptor-2.0.15-libxml2-2.11.patch
new file mode 100644
index 000000000000..605301ca0fd1
--- /dev/null
+++ b/raptor-2.0.15-libxml2-2.11.patch
@@ -0,0 +1,30 @@
+https://bugs.gentoo.org/906227
+https://github.com/dajobe/raptor/issues/59
+https://github.com/dajobe/raptor/pull/58
+
+From 4dbc4c1da2a033c497d84a1291c46f416a9cac51 Mon Sep 17 00:00:00 2001
+From: David Anes <david.anes@suse.com>
+Date: Thu, 4 May 2023 11:54:02 +0200
+Subject: [PATCH] Remove the access to entities 'checked' private symbol for
+ libxml2 2.11.0
+
+Since version 2.11.0, some private symbols that were never intended
+as public API/ABI have been removed from libxml2, therefore the field
+'checked' is no longer present and raptor fails to build in this
+scenario.
+--- a/src/raptor_libxml.c
++++ b/src/raptor_libxml.c
+@@ -246,10 +246,11 @@ raptor_libxml_getEntity(void* user_data, const xmlChar *name)
+
+ ret->owner = 1;
+
+-#if LIBXML_VERSION >= 20627
++#if LIBXML_VERSION >= 20627 && LIBXML_VERSION < 21100
+ /* Checked field was released in 2.6.27 on 2006-10-25
+ * http://git.gnome.org/browse/libxml2/commit/?id=a37a6ad91a61d168ecc4b29263def3363fff4da6
+ *
++ * and was later removed in version 2.11.0
+ */
+
+ /* Mark this entity as having been checked - never do this again */
+