summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Bezerra2019-03-29 00:09:43 -0300
committerRodrigo Bezerra2019-03-29 00:09:43 -0300
commit91dd8d03ce8b17608d8884a2b554e448230b7178 (patch)
treec3a2b7bf76a928f80bce383ebba02ca31f235c3d
parent5f6affb26cc23c0a187deac2dbf9bbd081642ae0 (diff)
downloadaur-91dd8d03ce8b17608d8884a2b554e448230b7178.tar.gz
Update PKGBUILD
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD76
2 files changed, 46 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bb9da12b067..efa634c16476 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,18 @@
-# Generated by mksrcinfo v8
-# Sun Nov 18 15:30:02 UTC 2018
pkgbase = lib32-rtmpdump
- pkgdesc = Tool to download rtmp streams (lib32)
+ pkgdesc = Tool to download rtmp streams (32 bit)
pkgver = 2.4.r96.fa8646d
- pkgrel = 4
+ pkgrel = 5
epoch = 1
url = http://rtmpdump.mplayerhq.hu/
arch = x86_64
license = GPL2
license = LGPL2.1
makedepends = git
- depends = lib32-glibc
depends = lib32-gnutls
- depends = lib32-zlib
depends = rtmpdump
- provides = librtmp.so
options = !makeflags
source = git+https://git.ffmpeg.org/rtmpdump#commit=fa8646d
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = lib32-rtmpdump
diff --git a/PKGBUILD b/PKGBUILD
index a07a589cd34c..9f98b1886eae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,61 @@
-# Maintainer: GordonGR <ntheo1979@gmail.com>
+# Maintainer: Rodrigo Bezerra <rodrigobezerra21 at gmail dot com>
+# Contributor: GordonGR <ntheo1979@gmail.com>
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: xduugu
# Contributor: Elis Hughes <elishughes@googlemail.com>
pkgname=lib32-rtmpdump
-_pkgname=rtmpdump
-epoch=1
pkgver=2.4.r96.fa8646d
-pkgrel=4
-pkgdesc='Tool to download rtmp streams (lib32)'
-arch=('x86_64')
+pkgrel=5
+epoch=1
+pkgdesc='Tool to download rtmp streams (32 bit)'
+arch=(x86_64)
url='http://rtmpdump.mplayerhq.hu/'
-license=('GPL2' 'LGPL2.1')
-depends=('lib32-glibc' 'lib32-gnutls' 'lib32-zlib' "${_pkgname}")
-makedepends=('git')
-provides=('librtmp.so')
-options=('!makeflags')
+license=(GPL2 LGPL2.1)
+depends=(lib32-gnutls rtmpdump)
+makedepends=(git)
+options=(!makeflags)
_commit='fa8646d'
source=("git+https://git.ffmpeg.org/rtmpdump#commit=${_commit}")
-md5sums=('SKIP')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd rtmpdump
+
+ _ver_name='2.4'
+ _ver_commit='c28f1bab7822de97353849e7787b59e50bbb1428'
+
+ echo "${_ver_name}.r$(git rev-list --count ${_ver_commit}..HEAD).${_commit}"
+}
prepare() {
-cd rtmpdump
-sed -e 's/^CRYPTO=OPENSSL/#CRYPTO=OPENSSL/' -e 's/#CRYPTO=GNUTLS/CRYPTO=GNUTLS/' -i Makefile -i librtmp/Makefile
-sed -i -e 's:gcc:gcc -m32:' Makefile librtmp/Makefile
-sed -i -e 's/host_cpu\=\"\${host\%\%-\*}\"/host_cpu\="i386"/' Makefile librtmp/Makefile
-sed -i -e 's/march\=\"\${march\%\%-\*}\"/march\="i386"/' Makefile librtmp/Makefile
+ cd rtmpdump
+
+ sed -e 's/^CRYPTO=OPENSSL/#CRYPTO=OPENSSL/' -e 's/#CRYPTO=GNUTLS/CRYPTO=GNUTLS/' -i Makefile -i librtmp/Makefile
+ sed -i -e 's:gcc:gcc -m32:' Makefile librtmp/Makefile
+ sed -i -e 's/host_cpu\=\"\${host\%\%-\*}\"/host_cpu\="i386"/' Makefile librtmp/Makefile
+ sed -i -e 's/march\=\"\${march\%\%-\*}\"/march\="i386"/' Makefile librtmp/Makefile
}
build() {
-cd rtmpdump
-make \
- OPT="$CFLAGS" \
- XLDFLAGS="$LDFLAGS"
+ cd rtmpdump
+
+ make \
+ OPT="$CFLAGS" \
+ XLDFLAGS="$LDFLAGS"
}
package() {
-cd rtmpdump
-make \
- prefix='/usr' \
- sbindir='/usr/bin' \
- mandir='/usr/share/man' \
- DESTDIR="${pkgdir}" \
- libdir='/usr/lib32' \
- install
-
-rm -rf "${pkgdir}/usr"/{bin,include,sbin,share}
-
-} \ No newline at end of file
+ cd rtmpdump
+
+ make \
+ DESTDIR="${pkgdir}" \
+ prefix='/usr' \
+ sbindir='/usr/bin' \
+ mandir='/usr/share/man' \
+ libdir='/usr/lib32' \
+ install
+
+ rm -rf "${pkgdir}/usr"/{bin,include,share}
+}