summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororumin2016-06-06 16:46:58 +0900
committerorumin2016-06-06 16:46:58 +0900
commit64b4302dff232b998fd7f7ec114439ff025f2808 (patch)
tree36f10ad44082fdf66c1d174c24a0e9c234eacd54
downloadaur-64b4302dff232b998fd7f7ec114439ff025f2808.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8a315bb51c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Jun 6 07:46:54 UTC 2016
+pkgbase = lib32-sbc
+ pkgdesc = Bluetooth Subband Codec (SBC) library (32-bit)
+ pkgver = 1.3
+ pkgrel = 1
+ url = http://www.bluez.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ depends = lib32-glibc
+ depends = sbc
+ source = http://www.kernel.org/pub/linux/bluetooth/sbc-1.3.tar.xz
+ md5sums = 2d8b7841f2c11ab287718d562f2b981c
+
+pkgname = lib32-sbc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c60bf78cdddf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: orumin <dev@orum.in>
+
+_basename=sbc
+pkgname="lib32-$_basename"
+pkgver=1.3
+pkgrel=1
+pkgdesc="Bluetooth Subband Codec (SBC) library (32-bit)"
+arch=('i686' 'x86_64')
+url="http://www.bluez.org/"
+license=('GPL' 'LGPL')
+depends=('lib32-glibc' 'sbc')
+source=(http://www.kernel.org/pub/linux/bluetooth/$_basename-$pkgver.tar.xz)
+md5sums=('2d8b7841f2c11ab287718d562f2b981c')
+
+build() {
+ cd $_basename-$pkgver
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./configure --prefix=/usr --disable-static --disable-tester \
+ --build=i686-pc-linux-gnu --libdir=/usr/lib32
+ make
+}
+
+package() {
+ cd $_basename-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ cd "$pkgdir"/usr
+ rm -r bin include
+}