summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2022-09-03 14:41:02 -0500
committerHurricanePootis2022-09-03 14:41:02 -0500
commitd7650b45784c33dd42c4541aa0f8abb81e4f8b56 (patch)
tree7a76783e39297d49a5499b31869f02318002c8a1
parentb27d49fe7b946b8acbf45b7531e907e83e3601c4 (diff)
downloadaur-d7650b45784c33dd42c4541aa0f8abb81e4f8b56.tar.gz
Fix pkgver()
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 3 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ecb2ef9a226a..00ee5ee72d5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-sdl12-compat-git
pkgdesc = An SDL-1.2 compatibility layer that uses SDL 2.0 behind the scenes.
- pkgver = 1.2.52.r33.g9403529
+ pkgver = 1.2.54.r6.g4d814ba
pkgrel = 1
url = https://github.com/libsdl-org/sdl12-compat
arch = x86_64
@@ -14,7 +14,6 @@ pkgbase = lib32-sdl12-compat-git
provides = lib32-sdl12-compat
conflicts = lib32-sdl
conflicts = lib32-sdl12-compat
- replaces = lib32-sdl<1:1.2.15+r406+gf1caf909
source = git+https://github.com/libsdl-org/sdl12-compat.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7b7d6acb5d64..9fe0926e3353 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=lib32-sdl12-compat-git
_pkgbase=sdl12-compat
-pkgver=1.2.52.r33.g9403529
+pkgver=1.2.54.r6.g4d814ba
pkgrel=1
pkgdesc="An SDL-1.2 compatibility layer that uses SDL 2.0 behind the scenes."
arch=("x86_64")
@@ -14,14 +14,13 @@ conflicts=('lib32-sdl')
provides=('lib32-sdl=1.12.15')
conflicts=('lib32-sdl' 'lib32-sdl12-compat')
provides=('lib32-sdl=1:1.2.15+r406+gf1caf909-1' 'lib32-sdl12-compat')
-replaces=('lib32-sdl<1:1.2.15+r406+gf1caf909')
source=("git+https://github.com/libsdl-org/sdl12-compat.git")
sha256sums=('SKIP')
pkgver() {
cd "$_pkgbase"
- git describe --long --tags | sed 's/^release-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/^release-//;s/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/^prerelease.//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare(){