summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2025-03-11 07:57:12 -0500
committerHurricanePootis2025-03-11 07:57:12 -0500
commit29652ea3f480cd924a7429efebc074175c05821f (patch)
tree9934fc8cc6cbdacf27bca0b56fbc43b192f897b7
parentfb9fbbae47ad2924a639953e0258a61297d6d189 (diff)
downloadaur-29652ea3f480cd924a7429efebc074175c05821f.tar.gz
upgpkg: 2.23.2-2: fix pipewire
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a33ae0da8c1e..41fc15989ced 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-sdl2
pkgdesc = A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard
pkgver = 2.32.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.libsdl.org
arch = x86_64
license = Zlib
@@ -34,6 +34,8 @@ pkgbase = lib32-sdl2
optdepends = lib32-libpulse: PulseAudio audio driver
optdepends = lib32-pipewire: PipeWire audio driver
source = https://github.com/libsdl-org/SDL/releases/download/release-2.32.2/SDL2-2.32.2.tar.gz
+ source = pipewire.patch::https://github.com/libsdl-org/SDL/commit/d35bef64e913dd7d5dd3153a4b61f10ef837dad6.patch
sha512sums = 9a608974a69b97fd5589bf8feed4742498f8f07731bcd5b99dd518089acda8b9b4216197b6adf7ca79ef1a9fe47c542033eefe94763e66229b1d9ba5207da5c5
+ sha512sums = cf84c2d4f6d72db976b95a546c0ac48c1454b205f57452ec8d4fc716105eabdf3e2972da9ad25aa84b3930a5d6099858ff375ec085ab3504965fe5d2b6677d0e
pkgname = lib32-sdl2
diff --git a/PKGBUILD b/PKGBUILD
index eed06ff40063..dbe53762e51d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=lib32-sdl2
pkgver=2.32.2
-pkgrel=1
+pkgrel=2
pkgdesc='A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard'
arch=(x86_64)
url=https://www.libsdl.org
@@ -44,8 +44,15 @@ optdepends=(
'lib32-libpulse: PulseAudio audio driver'
'lib32-pipewire: PipeWire audio driver'
)
-source=("https://github.com/libsdl-org/SDL/releases/download/release-${pkgver}/SDL2-${pkgver}.tar.gz")
-sha512sums=('9a608974a69b97fd5589bf8feed4742498f8f07731bcd5b99dd518089acda8b9b4216197b6adf7ca79ef1a9fe47c542033eefe94763e66229b1d9ba5207da5c5')
+source=("https://github.com/libsdl-org/SDL/releases/download/release-${pkgver}/SDL2-${pkgver}.tar.gz"
+ "pipewire.patch::https://github.com/libsdl-org/SDL/commit/d35bef64e913dd7d5dd3153a4b61f10ef837dad6.patch")
+sha512sums=('9a608974a69b97fd5589bf8feed4742498f8f07731bcd5b99dd518089acda8b9b4216197b6adf7ca79ef1a9fe47c542033eefe94763e66229b1d9ba5207da5c5'
+ 'cf84c2d4f6d72db976b95a546c0ac48c1454b205f57452ec8d4fc716105eabdf3e2972da9ad25aa84b3930a5d6099858ff375ec085ab3504965fe5d2b6677d0e')
+
+prepare() {
+ cd "$srcdir/SDL2-$pkgver"
+ patch -p1 < "$srcdir/pipewire.patch"
+}
build() {
export CC='gcc -m32'