summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2019-09-22 19:54:24 -0400
committerVincent Grande2019-09-22 19:54:24 -0400
commit7b795dd8892c0252c18905e3394102ce2646bf6d (patch)
tree8cf4a0bf864f6671ca0ad47ea976b3b7880d38f3
parent118480187a51bd78de7b878d0d4020feee6cfd2a (diff)
downloadaur-7b795dd8892c0252c18905e3394102ce2646bf6d.tar.gz
test thing
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD29
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f215c66988f..05b893e73ef3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,6 @@ pkgbase = lib32-sdl2-hg
url = https://www.libsdl.org
arch = x86_64
license = MIT
- makedepends = gcc-multilib
makedepends = lib32-alsa-lib
makedepends = lib32-mesa
makedepends = lib32-libpulse
@@ -16,8 +15,8 @@ pkgbase = lib32-sdl2-hg
makedepends = wayland-protocols
makedepends = lib32-libxss
makedepends = cmake
- makedepends = jack
makedepends = lib32-tslib
+ makedepends = mercurial
depends = lib32-glibc
depends = lib32-libxext
depends = lib32-libxrender
@@ -28,6 +27,7 @@ pkgbase = lib32-sdl2-hg
optdepends = lib32-alsa-lib: ALSA audio driver
optdepends = lib32-libpulse: PulseAudio audio driver
optdepends = lib32-jack: JACK audio driver
+ optdepends = jack: JACK audio support
provides = lib32-sdl2
conflicts = lib32-sdl2
source = hg+http://hg.libsdl.org/SDL#branch=default
diff --git a/PKGBUILD b/PKGBUILD
index 2c9844d49ddf..5e4727cc75be 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,12 +12,13 @@ url="https://www.libsdl.org"
license=('MIT')
depends=('lib32-glibc' 'lib32-libxext' 'lib32-libxrender' 'lib32-libx11' 'lib32-libgl'
'lib32-libxcursor' 'sdl2')
-makedepends=('gcc-multilib' 'lib32-alsa-lib' 'lib32-mesa' 'lib32-libpulse' 'lib32-libxrandr'
+makedepends=('lib32-alsa-lib' 'lib32-mesa' 'lib32-libpulse' 'lib32-libxrandr'
'lib32-libxinerama' 'lib32-wayland' 'lib32-libxkbcommon' 'wayland-protocols'
- 'lib32-libxss' 'cmake' 'jack' 'lib32-tslib')
+ 'lib32-libxss' 'cmake' 'lib32-tslib' 'mercurial')
optdepends=('lib32-alsa-lib: ALSA audio driver'
'lib32-libpulse: PulseAudio audio driver'
- 'lib32-jack: JACK audio driver')
+ 'lib32-jack: JACK audio driver'
+ 'jack: JACK audio support')
provides=(lib32-sdl2)
conflicts=(lib32-sdl2)
source=("hg+http://hg.libsdl.org/SDL#branch=default")
@@ -35,24 +36,27 @@ pkgver() {
}
prepare() {
- cd SDL
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
- sed -i 's|lib/cmake|lib32/cmake|' CMakeLists.txt
+ #fix libdir
+ sed -i 's|lib/cmake|lib32/cmake|' SDL/CMakeLists.txt
# Don't try to link against ibus
- sed -i '/pkg_search_module.*ibus-1.0/d' CMakeLists.txt
-
- mkdir build
+ sed -i '/pkg_search_module.*ibus-1.0/d' SDL/CMakeLists.txt
}
build() {
- cd SDL/build
+ cd build
export CC='gcc -m32'
export CXX='g++ -m32'
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
- cmake .. \
+ cmake ../SDL \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_SUFFIX=32 \
-DSDL_STATIC=OFF \
@@ -70,9 +74,8 @@ build() {
}
package() {
- cd SDL/build
-
- make DESTDIR="${pkgdir}" install
+
+ make DESTDIR="${pkgdir}" -C build install
rm -rf "${pkgdir}"/usr/{bin,include,share}
sed -i "s/libSDL2\.a/libSDL2main.a/g" "$pkgdir"/usr/lib32/cmake/SDL2/SDL2Targets-noconfig.cmake