summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGhettoGirl2016-08-21 11:45:58 +0200
committerGhettoGirl2016-08-21 11:45:58 +0200
commitb2efd73adc4fd52e11383e35fc9edcc9514b338a (patch)
tree39f2a1986941fc101d314407cb766977d1784462
downloadaur-b2efd73adc4fd52e11383e35fc9edcc9514b338a.tar.gz
Initial commit
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD54
-rw-r--r--lib32-sdl2-ime-support.install10
3 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77b5287c0d58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+# Generated by mksrcinfo v8
+# Sun Aug 21 09:45:30 UTC 2016
+pkgbase = lib32-sdl2-ime-support
+ pkgdesc = A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2) [with IME support] (32-bit support)
+ pkgver = 2.0.4
+ pkgrel = 1
+ url = http://www.libsdl.org
+ install = lib32-sdl2-ime-support.install
+ arch = x86_64
+ license = MIT
+ makedepends = gcc-multilib
+ makedepends = lib32-alsa-lib
+ makedepends = lib32-mesa
+ makedepends = lib32-libpulse
+ makedepends = lib32-libxinerama
+ makedepends = lib32-libxkbcommon
+ makedepends = lib32-libxrandr
+ makedepends = lib32-fcitx
+ depends = lib32-libgl
+ depends = lib32-libx11
+ depends = lib32-libxext
+ depends = lib32-libxrender
+ depends = sdl2-ime-support
+ optdepends = alsa-lib: ALSA audio driver
+ optdepends = libpulse: PulseAudio audio driver
+ optdepends = lib32-fcitx: fcitx input support
+ optdepends = ibus: IBus input support
+ provides = lib32-sdl2=2.0.4
+ conflicts = lib32-sdl2
+ source = git+https://github.com/timxx/SDL-fcitx#branch=release-2.0.4
+ md5sums = SKIP
+
+pkgname = lib32-sdl2-ime-support
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06b4e736099a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: GhettoGirl <github.com/GhettoGirl>
+
+pkgname=lib32-sdl2-ime-support
+pkgver=2.0.4
+pkgrel=1
+pkgdesc="A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2) [with IME support] (32-bit support)"
+arch=('x86_64')
+url="http://www.libsdl.org"
+license=('MIT')
+depends=('lib32-libgl' 'lib32-libx11' 'lib32-libxext' 'lib32-libxrender' 'sdl2-ime-support')
+provides=('lib32-sdl2=2.0.4')
+conflicts=('lib32-sdl2')
+install="$pkgname.install"
+makedepends=('gcc-multilib' 'lib32-alsa-lib' 'lib32-mesa' 'lib32-libpulse'
+ 'lib32-libxinerama' 'lib32-libxkbcommon' 'lib32-libxrandr'
+ 'lib32-fcitx')
+optdepends=('alsa-lib: ALSA audio driver'
+ 'libpulse: PulseAudio audio driver'
+ 'lib32-fcitx: fcitx input support'
+ 'ibus: IBus input support')
+source=("git+https://github.com/timxx/SDL-fcitx#branch=release-$pkgver")
+md5sums=('SKIP')
+
+build() {
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ cd SDL-fcitx
+ ./autogen.sh
+ mkdir -p build && cd build
+
+ ../configure \
+ --prefix='/usr' \
+ --libdir='/usr/lib32' \
+ --enable-{alsa,pulseaudio-shared,sdl-dlopen} \
+ --disable-{arts,esd,nas} \
+ --disable-input-tslib \
+ --disable-video-wayland \
+ --disable-rpath \
+ --enable-ibus \
+ --enable-fcitx
+ make -j$(nproc)
+}
+
+package() {
+ cd SDL-fcitx/build
+
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/usr/{bin,include,share}
+
+ install -dm 755 "${pkgdir}"/usr/share/licenses
+ ln -s sdl2 "${pkgdir}"/usr/share/licenses/lib32-sdl2
+}
diff --git a/lib32-sdl2-ime-support.install b/lib32-sdl2-ime-support.install
new file mode 100644
index 000000000000..c647a266afbf
--- /dev/null
+++ b/lib32-sdl2-ime-support.install
@@ -0,0 +1,10 @@
+
+post_install() {
+ echo "=== SDL2 with IME support ==="
+ echo "To enable advanced input methods in SDL2 applications, set the"
+ echo "environment variable SDL_IM_MODULE either to 'fcitx' or 'ibus'"
+}
+
+post_upgrade() {
+ post_install
+}