summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-02-14 02:52:38 -0500
committerVincent Grande2021-02-14 02:52:38 -0500
commit47961045086e57b52f07dac954ff5da4092d67eb (patch)
tree44d03554aece62a5699d90f33383f4f6cd43a3bd
downloadaur-47961045086e57b52f07dac954ff5da4092d67eb.tar.gz
initial upload
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD54
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f3405a39f4c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = lib32-sdl2_mixer-minimal-git
+ pkgdesc = A simple multi-channel audio mixer
+ pkgver = 2.0.4
+ pkgrel = 1
+ url = https://www.libsdl.org/projects/SDL_mixer/
+ arch = x86_64
+ license = MIT
+ makedepends = gcc-multilib
+ makedepends = git
+ depends = lib32-glibc
+ depends = lib32-sdl2
+ depends = sdl2_mixer
+ optdepends = lib32-fluidsynth: MIDI software synth, replaces built-in timidity
+ optdepends = lib32-libmodplug: tracker support
+ optdepends = lib32-mpg123: mp3 support
+ optdepends = lib32-libvorbis: vorbis support
+ optdepends = lib32-flac: flac support
+ provides = lib32-sdl2_mixer
+ conflicts = lib32-sdl2_mixer
+ source = git+https://github.com/libsdl-org/SDL_mixer
+ sha256sums = SKIP
+
+pkgname = lib32-sdl2_mixer-minimal-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60fa4487e3c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: carstene1ns <arch.carsten@teibes.de>
+# Contributor: Jameson Pugh <imntreal@gmail.com>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+
+pkgname=lib32-sdl2_mixer-minimal-git
+pkgver=2.0.4
+pkgrel=1
+pkgdesc='A simple multi-channel audio mixer'
+arch=('x86_64')
+url='https://www.libsdl.org/projects/SDL_mixer/'
+license=('MIT')
+depends=('lib32-glibc' 'lib32-sdl2' 'sdl2_mixer')
+makedepends=('gcc-multilib' 'git')
+optdepends=('lib32-fluidsynth: MIDI software synth, replaces built-in timidity'
+ 'lib32-libmodplug: tracker support'
+ 'lib32-mpg123: mp3 support'
+ 'lib32-libvorbis: vorbis support'
+ 'lib32-flac: flac support')
+provides=(lib32-sdl2_mixer)
+conflicts=(lib32-sdl2_mixer)
+source=("git+https://github.com/libsdl-org/SDL_mixer")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd SDL
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd SDL_mixer
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./autogen.sh
+ ./configure \
+ --prefix='/usr' --libdir='/usr/lib32' --disable-static --disable-music-cmd --disable-music-wave --disable-music-mod --disable-music-mod-modplug --disable-music-mod-modplug-shared --disable-music-mod-mikmod --disable-music-mod-mikmod-shared --disable-music-midi --disable-music-midi-timidity --disable-music-midi-native --disable-music-midi-fluidsynth --disable-music-midi-fluidsynth-shared --disable-music-ogg --disable-music-ogg-tremor --disable-music-ogg-shared --disable-music-flac --disable-music-flac-shared --disable-music-mp3 --disable-music-mp3-mad-gpl --disable-music-mp3-mad-gpl-dithering --disable-music-mp3-mpg123 --disable-music-mp3-mpg123-shared --disable-music-opus --disable-music-opus-shared
+ make
+}
+
+package() {
+ cd SDL_mixer
+
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/usr/include
+
+ install -dm 755 "${pkgdir}"/usr/share/licenses
+ ln -s sdl2_mixer "${pkgdir}"/usr/share/licenses/lib32-sdl2_mixer
+}
+
+# vim: ts=2 sw=2 et: