summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2024-06-26 12:30:40 -0500
committerHurricanePootis2024-06-26 12:30:40 -0500
commita3c91318e4326828974536852e611ee293006ed0 (patch)
treeb90ab2ed83f56554b000ca60dda8890971eeeec4
downloadaur-a3c91318e4326828974536852e611ee293006ed0.tar.gz
Initial commit 3.1.1
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD51
2 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e966f5f3e1e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = lib32-sdl3
+ pkgdesc = A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 3)
+ pkgver = 3.1.1
+ pkgrel = 1
+ url = https://www.libsdl.org
+ arch = x86_64
+ arch = i686
+ license = Zlib
+ makedepends = lib32-alsa-lib
+ makedepends = lib32-mesa
+ makedepends = lib32-libpulse
+ makedepends = lib32-libxrandr
+ makedepends = lib32-libxinerama
+ makedepends = lib32-wayland
+ makedepends = lib32-libxkbcommon
+ makedepends = wayland-protocols
+ makedepends = lib32-libxss
+ makedepends = cmake
+ makedepends = lib32-jack
+ makedepends = ninja
+ makedepends = lib32-pipewire
+ makedepends = lib32-libdecor
+ makedepends = git
+ depends = sdl3
+ depends = lib32-glibc
+ depends = lib32-libxext
+ depends = lib32-libxrender
+ depends = lib32-libx11
+ depends = lib32-libgl
+ depends = lib32-libxcursor
+ depends = hidapi
+ depends = lib32-libusb
+ optdepends = lib32-alsa-lib: ALSA audio driver
+ optdepends = lib32-libpulse: PulseAudio audio driver
+ optdepends = lib32-jack: JACK audio driver
+ optdepends = lib32-pipewire: PipeWire audio driver
+ optdepends = lib32-libdecor: Wayland client decorations
+ source = git+https://github.com/libsdl-org/SDL.git#tag=prerelease-3.1.1
+ sha256sums = 170e00bcd9e9a431198fd67782f070c068e17c2af35367b840409230b5cd43b2
+
+pkgname = lib32-sdl3
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9669d135ae69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: HurricanePootis <hurricanepootis@protonmail.com>
+# Contributor: VitalyR <vr AT vitalyr DOT com>
+# Contributor: HurricanePootis <hurricanepootis@protonmail.com>
+# Contributor: Christer Solskogen <christer.solskogen@gmail.com>
+
+pkgname=lib32-sdl3
+pkgver=3.1.1
+pkgrel=1
+pkgdesc="A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 3)"
+arch=('x86_64' 'i686')
+url="https://www.libsdl.org"
+license=('Zlib')
+depends=('sdl3' 'lib32-glibc' 'lib32-libxext' 'lib32-libxrender' 'lib32-libx11' 'lib32-libgl' 'lib32-libxcursor' 'hidapi' 'lib32-libusb')
+makedepends=('lib32-alsa-lib' 'lib32-mesa' 'lib32-libpulse' 'lib32-libxrandr' 'lib32-libxinerama' 'lib32-wayland' 'lib32-libxkbcommon'
+ 'wayland-protocols' 'lib32-libxss' 'cmake' 'lib32-jack' 'ninja' 'lib32-pipewire'
+ 'lib32-libdecor' 'git')
+optdepends=('lib32-alsa-lib: ALSA audio driver'
+ 'lib32-libpulse: PulseAudio audio driver'
+ 'lib32-jack: JACK audio driver'
+ 'lib32-pipewire: PipeWire audio driver'
+ 'lib32-libdecor: Wayland client decorations')
+source=("git+https://github.com/libsdl-org/SDL.git#tag=prerelease-${pkgver}")
+sha256sums=('170e00bcd9e9a431198fd67782f070c068e17c2af35367b840409230b5cd43b2')
+
+build() {
+ cd "$srcdir"
+ #CFLAGS+=" -ffat-lto-objects"
+ export CFLAGS+=" -m32"
+ export CXXFLAGS+=" -m32"
+ export LDFLAGS+=" -m32"
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+ cmake -S SDL -B build -G Ninja \
+ -D CMAKE_BUILD_TYPE=None \
+ -D SDL_HIDAPI_LIBUSB=ON \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D CMAKE_INSTALL_LIBDIR=lib32 \
+ -D SDL_RPI=OFF \
+ -D SDL_STATIC=OFF \
+ -D SDL_RPATH=OFF
+ cmake --build build
+}
+
+package() {
+ cd "$srcdir"
+ DESTDIR="${pkgdir}" cmake --install build
+ rm -rf "${pkgdir}/usr/lib/cmake"
+ rm -rf "${pkgdir}/usr/include"
+ rm -rf "${pkgdir}/usr/share/man"
+ mv "${pkgdir}/usr/share/licenses/SDL3" "${pkgdir}/usr/share/licenses/lib32-sdl3-git"
+}
+