summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-08-18 12:16:10 +0200
committerCarsten Teibes2014-08-18 12:16:10 +0200
commit6708e69ef6aa7750be79a8000519280fcc07bd43 (patch)
treee4029cf3533d9f2e6f9912a8df5d8cf76a250a97
downloadaur-6708e69ef6aa7750be79a8000519280fcc07bd43.tar.gz
[add] lib32-sdl_sound 1.0.3
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f5d38c5da59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = lib32-sdl_sound
+ pkgdesc = A library to decode several popular sound file formats, such as .WAV and .MP3 (32 bit)
+ pkgver = 1.0.3
+ pkgrel = 6
+ url = http://icculus.org/SDL_sound/
+ arch = x86_64
+ license = LGPL
+ depends = lib32-sdl
+ depends = lib32-libmikmod
+ depends = libvorbis
+ depends = lib32-flac
+ depends = lib32-speex
+ depends = lib32-smpeg
+ depends = lib32-libmodplug
+ depends = sdl_sound
+ source = http://icculus.org/SDL_sound/downloads/SDL_sound-1.0.3.tar.gz
+ sha256sums = 3999fd0bbb485289a52be14b2f68b571cb84e380cc43387eadf778f64c79e6df
+
+pkgname = lib32-sdl_sound
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..202fae190136
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: trya <tryagainprod@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=lib32-sdl_sound
+pkgver=1.0.3
+pkgrel=6
+pkgdesc="A library to decode several popular sound file formats, such as .WAV and .MP3 (32 bit)"
+arch=('x86_64')
+url="http://icculus.org/SDL_sound/"
+license=('LGPL')
+depends=('lib32-sdl' 'lib32-libmikmod' 'libvorbis' 'lib32-flac' 'lib32-speex' 'lib32-smpeg'
+ 'lib32-libmodplug' 'sdl_sound')
+source=("http://icculus.org/SDL_sound/downloads/SDL_sound-$pkgver.tar.gz")
+sha256sums=('3999fd0bbb485289a52be14b2f68b571cb84e380cc43387eadf778f64c79e6df')
+
+build() {
+ cd SDL_sound-$pkgver
+
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ export SDL_CONFIG=/usr/bin/sdl-config-32
+ export CPPFLAGS="$CPPFLAGS -I/usr/include/smpeg"
+ ./configure --prefix=/usr --libdir=/usr/lib32 --disable-static
+ make
+}
+
+package() {
+ cd SDL_sound-$pkgver
+ make DESTDIR="$pkgdir" install
+ # remove stuff already present in sdl_sound package
+ rm -rf "$pkgdir"/usr/{bin,include}
+}