summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Demers2020-05-05 10:32:06 -0400
committerAlexandre Demers2020-05-05 10:32:06 -0400
commitb65f23f8f262378f3ce1d8935259e9ba6ef06ff0 (patch)
tree36f42c25dfc9f56d1cb729e3f7d2a26e223cf4af
parent07897a23df507af2dc3ac90bfb30b727f4d19ac4 (diff)
downloadaur-b65f23f8f262378f3ce1d8935259e9ba6ef06ff0.tar.gz
Keep the bin folder (by renaming glslc)
Since there is no distinct package to separate the libraries from the executables, both should be kept in case someone should need any of them. Use the same naming scheme as found in lib32-shaderc-git (there is no naming convention for 32 bit executables on 64 bit architecture to the best of my knowledges and searches). Signed-off-by: Alexandre Demers <alexandre.f.demers@gmail.com>
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50fef1fd01a8..dc0fe3e606fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-shaderc
pkgdesc = Collection of tools, libraries and tests for shader compilation (32bit)
pkgver = 2020.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/google/shaderc
arch = x86_64
license = Apache
@@ -16,6 +16,7 @@ pkgbase = lib32-shaderc
depends = lib32-spirv-tools>=2019.5
depends = spirv-tools>=2019.5
provides = libshaderc_shared.so
+ conflicts = lib32-shaderc-git
source = shaderc-2020.0.tar.gz::https://github.com/google/shaderc/archive/v2020.0.tar.gz
sha512sums = 1971673d7a5fe77ef827c29db14112d4935c573c7c4f3b00fff3729334284d11640ee40c9e97ebcb2a14c6d5c6db0cf5e2ef6b2dfb59c759d1322c6d38624eb4
diff --git a/PKGBUILD b/PKGBUILD
index 5954839d1aa0..d6908debd888 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _pkgbasename=shaderc
pkgname=lib32-$_pkgbasename
pkgver=2020.0
-pkgrel=3
+pkgrel=4
pkgdesc='Collection of tools, libraries and tests for shader compilation (32bit)'
url='https://github.com/google/shaderc'
arch=('x86_64')
@@ -26,6 +26,7 @@ makedepends=(
'spirv-headers'
)
provides=('libshaderc_shared.so')
+conflicts=('lib32-shaderc-git')
source=(
"${_pkgbasename}-${pkgver}.tar.gz::https://github.com/google/shaderc/archive/v${pkgver}.tar.gz"
)
@@ -69,6 +70,12 @@ build() {
package() {
DESTDIR="${pkgdir}" ninja -C build install
- rm -r "${pkgdir}"/usr/{include,bin}
+
+ # Use the same naming scheme as the one in the lib32-shaderc-git package for coherence
+ for i in "${pkgdir}/usr/bin/"*; do
+ mv "$i" "$i"-32
+ done
+
+ rm -r "${pkgdir}"/usr/include
# install -Dm 644 ${_pkgbasename}-${pkgver}/glslc/glslc.1 -t "${pkgdir}/usr/share/man/man1"
}