summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2016-06-16 05:18:15 -0700
committerLlewelyn Trahaearn2016-06-16 05:18:15 -0700
commitcfac23db12510e32e56e642ec000c8b0aade480f (patch)
tree16888ac52b25f0c6eb5e5efc770f85c93f0522dd
parent8e8dc4e97c1c5c88e0595e0fb6c3d634c19a44b6 (diff)
downloadaur-cfac23db12510e32e56e642ec000c8b0aade480f.tar.gz
GCC 6.1.1 patch
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8889a94daf03..e45aa570a06d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,11 +21,15 @@ sha512sums=('SKIP')
build()
{
cd "${srcdir}/${pkgname#lib32-}"
- export CC="gcc -m32"
- export CXX="g++ -m32"
+
+ # Override the defaults with 32-bit options.
+ export CC='gcc -m32'
+ # GCC 6.1.1 introduced new behaviour that breaks things, using older standard allows successful build.
+ export CXX='g++ -m32 -std=gnu++03'
export LDFLAGS='-m32'
+ export PKG_CONFIG_LIBDIR='/usr/lib32/pkgconfig'
+
export LIBS="-lX11"
- export PKG_CONFIG_PATH=/usr/lib32/pkgconfig
./autogen.sh
./configure --prefix=/usr --libdir=/usr/lib32 --disable-static
make