summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSwyter2019-12-04 17:01:24 +0100
committerSwyter2019-12-04 17:01:24 +0100
commitec94cdc38a9ac0e7e40e9c0b1a71706fc7d1f288 (patch)
tree78f61c242aad0e7c528c0e8eec96cfed7237e237
downloadaur-ec94cdc38a9ac0e7e40e9c0b1a71706fc7d1f288.tar.gz
First version, I think.
Add the missing .SRCINFO. Use sha256 instead of sha1, just for kicks.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD47
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0fb63f5e3a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lib32-sndio
+ pkgdesc = A small audio and MIDI framework part of the OpenBSD project (32 bit)
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = http://www.sndio.org
+ arch = x86_64
+ license = ISC
+ depends = alsa-lib
+ depends = libbsd
+ backup = etc/default/sndiod
+ source = http://www.sndio.org/sndio-1.6.0.tar.gz
+ sha256sums = 99e0064ac11aceab24c73ed4630a31de401ff2f37689565b7b375682476f5bc1
+
+pkgname = lib32-sndio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75750356e7be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# AUR maintainer: Swyter <swyterzone+aur@gmail.com>
+# 64-bit Maintainer: Ivy Foster <code@escondida.tk>
+# Reference: PKGBUILD(5)
+
+pkgname=lib32-sndio
+pkgver=1.6.0
+pkgrel=1
+pkgdesc='A small audio and MIDI framework part of the OpenBSD project (32 bit)'
+arch=('x86_64')
+url='http://www.sndio.org'
+license=('ISC')
+
+# sndio can be built without libbsd, but there are a bunch of individual
+# ISC-licensed files by different authors to extract the licenses from
+# if done that way. Licenses are complicated.
+depends=(alsa-lib libbsd)
+
+source=("http://www.sndio.org/sndio-$pkgver.tar.gz")
+sha256sums=(99e0064ac11aceab24c73ed4630a31de401ff2f37689565b7b375682476f5bc1)
+backup=(etc/default/sndiod)
+
+build() {
+ # Modify environment to generate 32-bit ELF. Respects flags defined in makepkg.conf
+ export CFLAGS="-m32 ${CFLAGS}"
+ export CXXFLAGS="-m32 ${CXXFLAGS}"
+ export LDFLAGS="-m32 ${LDFLAGS}"
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+# export PKG_CONFIG_LIBDIR='/usr/lib32/pkgconfig'
+
+ cd "sndio-${pkgver}"
+
+ ./configure \
+ --enable-alsa \
+ --with-libbsd \
+ --prefix=/usr \
+ --libdir=/usr/lib32
+
+ make
+}
+
+package() {
+ cd "sndio-${pkgver}"
+ make DESTDIR="$pkgdir/" install
+
+ ln -s "libsndio.so.7.0" "$pkgdir"/usr/lib32/libsndio.so.6.1
+}
+