summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Bezerra2020-11-22 14:49:44 -0300
committerRodrigo Bezerra2020-11-22 14:49:44 -0300
commit4c304e2a4195975274c0d95eb203eb8314709fae (patch)
treefd7403e5e216f43a5a2bafe6f95501ff56d4dfea
parentb0fa74d5d2e149b2cfc3d540ac5cd0891602e3a1 (diff)
downloadaur-4c304e2a4195975274c0d95eb203eb8314709fae.tar.gz
Update to version 1.4.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD26
-rw-r--r--no-rpath.diff12
3 files changed, 13 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64d98eb527b2..f59ed3edfd8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-srt
pkgdesc = Secure Reliable Transport library (32-bit)
- pkgver = 1.4.1
+ pkgver = 1.4.2
pkgrel = 1
url = https://www.srtalliance.org/
arch = x86_64
@@ -11,10 +11,8 @@ pkgbase = lib32-srt
depends = lib32-gcc-libs
depends = lib32-openssl
depends = srt
- source = git+https://github.com/Haivision/srt#commit=9e52606fae3b32818b5b734d45d3358f4a95cf3f
- source = no-rpath.diff
+ source = git+https://github.com/Haivision/srt#commit=50b7af06f3a0a456c172b4cb3aceafa8a5cc0036
sha256sums = SKIP
- sha256sums = ce9a97d661d796da85a7e4faf9c70c27368d00eb505f85c03a31bba8f22e6847
pkgname = lib32-srt
diff --git a/PKGBUILD b/PKGBUILD
index 634cb1f2af8c..c0af7464f86b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_basename=srt
pkgname=lib32-srt
-pkgver=1.4.1
+pkgver=1.4.2
pkgrel=1
pkgdesc="Secure Reliable Transport library (32-bit)"
url="https://www.srtalliance.org/"
@@ -10,11 +10,10 @@ arch=(x86_64)
license=(MPL2)
depends=(lib32-gcc-libs lib32-openssl srt)
makedepends=(git cmake ninja)
-_commit=9e52606fae3b32818b5b734d45d3358f4a95cf3f # tags/v1.4.1
-source=("git+https://github.com/Haivision/srt#commit=$_commit"
- no-rpath.diff)
-sha256sums=('SKIP'
- 'ce9a97d661d796da85a7e4faf9c70c27368d00eb505f85c03a31bba8f22e6847')
+_commit=50b7af06f3a0a456c172b4cb3aceafa8a5cc0036 # tags/v1.4.2
+source=("git+https://github.com/Haivision/srt#commit=$_commit")
+sha256sums=('SKIP')
+
pkgver() {
cd $_basename
@@ -22,23 +21,19 @@ pkgver() {
git describe --tags | sed 's/^v//;s/-/+/g'
}
-prepare() {
- cd $_basename
-
- patch -Np1 -i ../no-rpath.diff
-}
-
build() {
export CC='gcc -m32'
export CXX='g++ -m32'
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
- cmake -Hsrt -Bbuild -GNinja \
+ cmake -S srt -B build -G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_BINDIR=bin \
-DCMAKE_INSTALL_LIBDIR=lib32 \
-DCMAKE_INSTALL_INCLUDEDIR=include \
- -DENABLE_TESTING=True
+ -DCMAKE_BUILD_TYPE=None \
+ -DENABLE_STATIC=ON \
+ -DENABLE_TESTING=ON
cmake --build build
}
@@ -46,11 +41,12 @@ build() {
check() {
cd build
+ ./uriparser-test
./utility-test
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
cd "$pkgdir"/usr
diff --git a/no-rpath.diff b/no-rpath.diff
deleted file mode 100644
index 364a81beb5c7..000000000000
--- a/no-rpath.diff
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git i/CMakeLists.txt w/CMakeLists.txt
-index e913122..2cc3c3d 100644
---- i/CMakeLists.txt
-+++ w/CMakeLists.txt
-@@ -634,7 +634,6 @@ macro(srt_make_application name)
- # be placed into the binrary directory anyway.
- # XXX not sure about Mac.
- # See this name used already in install(${TARGET_srt} LIBRARY DESTINATION...).
-- set(FORCE_RPATH LINK_FLAGS -Wl,-rpath,.,-rpath,../${CMAKE_INSTALL_LIBDIR} BUILD_WITH_INSTALL_RPATH TRUE INSTALL_RPATH_USE_LINK_PATH TRUE)
- endif()
-
- # We state that Darwin always uses CLANG compiler, which honors this flag the same way.