summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBehnam Momeni2020-01-31 17:56:15 +0330
committerBehnam Momeni2020-01-31 17:56:15 +0330
commit4997ac078a660aab071cf1806e45de31ed5052f3 (patch)
tree61f909c5050c149f8defb34e2d15fe4a3ff8dc21
parent4e4b52763683c6384be36a05e19e618aca26f3c9 (diff)
downloadaur-4997ac078a660aab071cf1806e45de31ed5052f3.tar.gz
Upgrading to version 5.6.0
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
-rw-r--r--suitesparse-link-tbb.patch11
-rw-r--r--suitesparse-no-demo.patch11
5 files changed, 45 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13e2c7e6392f..98d67b8ec1b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Fri Jan 31 14:26:01 UTC 2020
pkgbase = lib32-suitesparse
pkgdesc = A collection of sparse matrix libraries (32-bit)
- pkgver = 4.5.4
- pkgrel = 3
+ pkgver = 5.6.0
+ pkgrel = 1
url = http://faculty.cse.tamu.edu/davis/suitesparse.html
arch = x86_64
license = GPL
@@ -13,10 +15,10 @@ pkgbase = lib32-suitesparse
depends = lib32-intel-tbb
depends = suitesparse
options = staticlibs
- source = http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-4.5.4.tar.gz
- source = suitesparse-link-tbb.patch
- sha1sums = 33fb47e3140f1dd8cae10847a9344439d4aa66b2
- sha1sums = 4f0b3836e8c3c1ec5be01f988f136cee4a2cb936
+ source = suitesparse-5.6.0.tar.gz::https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/v5.6.0.tar.gz
+ source = suitesparse-no-demo.patch
+ sha512sums = c4dac62710501388fd58e52fe239723f83a94ff666410f711d42710485730d2821d3bb0ad937b40ac1a257e6da2ed317e30d74592b16ac3f959295965314d6dc
+ sha512sums = 68bed536bb5e05f95b2a95d4e5d6dd503c0682299840b569febdb3a66b77c81ed51c7d1add9ad0bb4e9e22bccfd87ac400ac2665fb9e5b7820f3c544178272b0
pkgname = lib32-suitesparse
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..467c6f619173
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+suitesparse-*.tar.gz
+lib32-suitesparse-*.pkg.tar.xz
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
index 6dece1e462b5..b52a8e055cf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: orumin <ev at orum.in>
+# Maintainer: Behnam Momeni <sbmomeni [at the] gmail [dot] com>
+# Contributor: orumin <ev at orum.in>
pkgname=lib32-suitesparse
-_basename=suitesparse
-pkgver=4.5.4
-pkgrel=3
+_pkgbase=suitesparse
+pkgver=5.6.0
+pkgrel=1
pkgdesc="A collection of sparse matrix libraries (32-bit)"
url="http://faculty.cse.tamu.edu/davis/suitesparse.html"
arch=('x86_64')
@@ -11,34 +12,31 @@ depends=('lib32-metis' 'lib32-lapack' 'lib32-intel-tbb' 'suitesparse')
makedepends=('gcc-fortran-multilib' 'cmake' 'chrpath')
license=('GPL')
options=('staticlibs')
-source=("http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-$pkgver.tar.gz" suitesparse-link-tbb.patch)
-sha1sums=('33fb47e3140f1dd8cae10847a9344439d4aa66b2'
- '4f0b3836e8c3c1ec5be01f988f136cee4a2cb936')
+source=($_pkgbase-$pkgver.tar.gz::"https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/v$pkgver.tar.gz"
+ "suitesparse-no-demo.patch")
+sha512sums=('c4dac62710501388fd58e52fe239723f83a94ff666410f711d42710485730d2821d3bb0ad937b40ac1a257e6da2ed317e30d74592b16ac3f959295965314d6dc'
+ '68bed536bb5e05f95b2a95d4e5d6dd503c0682299840b569febdb3a66b77c81ed51c7d1add9ad0bb4e9e22bccfd87ac400ac2665fb9e5b7820f3c544178272b0')
prepare() {
-# Fix linking with intel-tbb
- cd SuiteSparse
- patch -p1 -i ../suitesparse-link-tbb.patch
+ cd "${srcdir}/SuiteSparse-$pkgver"
+ patch -p1 -i ../suitesparse-no-demo.patch
}
build() {
- cd "$srcdir"/SuiteSparse
-
- CC="gcc -m32" CXX="g++ -m32" PKG_CONFIG_PATH='/usr/lib32/pkgconfig' \
- BLAS=-lblas TBB=-ltbb SPQR_CONFIG=-DHAVE_TBB MY_METIS_LIB=/usr/lib32/libmetis.so make
+ cd "${srcdir}/SuiteSparse-$pkgver"
+ export CC="gcc -m32" CXX="g++ -m32" PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+ export BLAS=-lblas TBB=-ltbb SPQR_CONFIG=-DHAVE_TBB MY_METIS_LIB=/usr/lib32/libmetis.so
+ make
}
-
package() {
- cd "${srcdir}"/SuiteSparse
- install -dm755 "${pkgdir}"/usr/{include,lib32}
+ cd "${srcdir}/SuiteSparse-$pkgver"
- CC="gcc -m32" CXX="g++ -m32" PKG_CONFIG_PATH='/usr/lib32/pkgconfig' \
- BLAS=-lblas TBB=-ltbb SPQR_CONFIG=-DHAVE_TBB MY_METIS_LIB=/usr/lib32/libmetis.so \
- make INSTALL_LIB="${pkgdir}"/usr/lib32 INSTALL_INCLUDE="${pkgdir}"/usr/include install
+ export CC="gcc -m32" CXX="g++ -m32" PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+ export BLAS=-lblas TBB=-ltbb SPQR_CONFIG=-DHAVE_TBB MY_METIS_LIB=/usr/lib32/libmetis.so
+ make INSTALL_LIB="${pkgdir}/usr/lib32" INSTALL_INCLUDE="${pkgdir}/usr/include" install
- rm -r "${pkgdir}"/usr/include
-
- # fix RPATH
- chrpath -d "$pkgdir"/usr/lib32/*
+ rm -r "${pkgdir}"/usr/include
+ chrpath -d "$pkgdir"/usr/lib32/*
}
+
diff --git a/suitesparse-link-tbb.patch b/suitesparse-link-tbb.patch
deleted file mode 100644
index 8ed1df29747b..000000000000
--- a/suitesparse-link-tbb.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- SuiteSparse/SPQR/Lib/Makefile.orig 2016-09-24 09:36:59.588640845 +0000
-+++ SuiteSparse/SPQR/Lib/Makefile 2016-09-24 09:37:14.248588339 +0000
-@@ -13,7 +13,7 @@
- include ../../SuiteSparse_config/SuiteSparse_config.mk
-
- # SPQR depends on CHOLMOD, AMD, COLAMD, LAPACK, the BLAS and SuiteSparse_config
--LDLIBS += -lamd -lcolamd -lcholmod -lsuitesparseconfig $(LAPACK) $(BLAS)
-+LDLIBS += -lamd -lcolamd -lcholmod -lsuitesparseconfig $(LAPACK) $(BLAS) $(TBB)
-
- # compile and install in SuiteSparse/lib
- library:
diff --git a/suitesparse-no-demo.patch b/suitesparse-no-demo.patch
new file mode 100644
index 000000000000..936cdf97ac53
--- /dev/null
+++ b/suitesparse-no-demo.patch
@@ -0,0 +1,11 @@
+--- SuiteSparse-5.6.0/Makefile.orig 2019-11-05 22:37:26.086135974 +0000
++++ SuiteSparse-5.6.0/Makefile 2019-11-05 22:37:37.549632429 +0000
+@@ -12,7 +12,7 @@
+ # Compile the default rules for each package
+ go: metis
+ ( cd SuiteSparse_config && $(MAKE) )
+- ( cd Mongoose && $(MAKE) CMAKE_OPTIONS='$(CMAKE_OPTIONS)' )
++ ( cd Mongoose && $(MAKE) library CMAKE_OPTIONS='$(CMAKE_OPTIONS)' )
+ ( cd AMD && $(MAKE) )
+ ( cd BTF && $(MAKE) )
+ ( cd CAMD && $(MAKE) )