summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBehnam Momeni2021-02-11 10:36:56 +0330
committerBehnam Momeni2021-02-11 10:36:56 +0330
commit8ffcc80472b08ead6359337532b35973a07e5b0b (patch)
tree4d7e6ea9877b0b598a326a4195889da3addfdded
parent4997ac078a660aab071cf1806e45de31ed5052f3 (diff)
downloadaur-8ffcc80472b08ead6359337532b35973a07e5b0b.tar.gz
Upgrade to upstream version 5.8.1
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD13
-rw-r--r--suitesparse-no-demo.patch8
4 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98d67b8ec1b7..1fb5263189ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jan 31 14:26:01 UTC 2020
+# Thu Feb 11 06:50:43 UTC 2021
pkgbase = lib32-suitesparse
pkgdesc = A collection of sparse matrix libraries (32-bit)
- pkgver = 5.6.0
+ pkgver = 5.8.1
pkgrel = 1
url = http://faculty.cse.tamu.edu/davis/suitesparse.html
arch = x86_64
@@ -14,11 +14,12 @@ pkgbase = lib32-suitesparse
depends = lib32-lapack
depends = lib32-intel-tbb
depends = suitesparse
+ depends = lib32-mpfr
options = staticlibs
- source = suitesparse-5.6.0.tar.gz::https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/v5.6.0.tar.gz
+ source = suitesparse-5.8.1.tar.gz::https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/v5.8.1.tar.gz
source = suitesparse-no-demo.patch
- sha512sums = c4dac62710501388fd58e52fe239723f83a94ff666410f711d42710485730d2821d3bb0ad937b40ac1a257e6da2ed317e30d74592b16ac3f959295965314d6dc
- sha512sums = 68bed536bb5e05f95b2a95d4e5d6dd503c0682299840b569febdb3a66b77c81ed51c7d1add9ad0bb4e9e22bccfd87ac400ac2665fb9e5b7820f3c544178272b0
+ sha512sums = 3d986157acd39968216880c2de30c54d72e0addd7318a04948c1b842ad9c876bcde32f292504d4540a4baa998a368dfc0db000606a2d00f61760a92d5b8c1cb8
+ sha512sums = f7bfd7fd8d8defd1e7dc1afdb05ed9fe32ab144b82052a6863b96b8c423521aca9560d093c82aca02da493473d5cda90482fd084f528b90f33590fae2cf5e4d9
pkgname = lib32-suitesparse
diff --git a/.gitignore b/.gitignore
index 467c6f619173..e5b982641214 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
suitesparse-*.tar.gz
lib32-suitesparse-*.pkg.tar.xz
+lib32-suitesparse-*.pkg.tar.zst
src/
pkg/
diff --git a/PKGBUILD b/PKGBUILD
index b52a8e055cf4..346d3bb3d90b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,20 @@
pkgname=lib32-suitesparse
_pkgbase=suitesparse
-pkgver=5.6.0
+pkgver=5.8.1
pkgrel=1
pkgdesc="A collection of sparse matrix libraries (32-bit)"
url="http://faculty.cse.tamu.edu/davis/suitesparse.html"
arch=('x86_64')
-depends=('lib32-metis' 'lib32-lapack' 'lib32-intel-tbb' 'suitesparse')
+depends=('lib32-metis' 'lib32-lapack' 'lib32-intel-tbb' 'suitesparse'
+ 'lib32-mpfr')
makedepends=('gcc-fortran-multilib' 'cmake' 'chrpath')
license=('GPL')
options=('staticlibs')
source=($_pkgbase-$pkgver.tar.gz::"https://github.com/DrTimothyAldenDavis/SuiteSparse/archive/v$pkgver.tar.gz"
"suitesparse-no-demo.patch")
-sha512sums=('c4dac62710501388fd58e52fe239723f83a94ff666410f711d42710485730d2821d3bb0ad937b40ac1a257e6da2ed317e30d74592b16ac3f959295965314d6dc'
- '68bed536bb5e05f95b2a95d4e5d6dd503c0682299840b569febdb3a66b77c81ed51c7d1add9ad0bb4e9e22bccfd87ac400ac2665fb9e5b7820f3c544178272b0')
+sha512sums=('3d986157acd39968216880c2de30c54d72e0addd7318a04948c1b842ad9c876bcde32f292504d4540a4baa998a368dfc0db000606a2d00f61760a92d5b8c1cb8'
+ 'f7bfd7fd8d8defd1e7dc1afdb05ed9fe32ab144b82052a6863b96b8c423521aca9560d093c82aca02da493473d5cda90482fd084f528b90f33590fae2cf5e4d9')
prepare() {
cd "${srcdir}/SuiteSparse-$pkgver"
@@ -25,7 +26,7 @@ prepare() {
build() {
cd "${srcdir}/SuiteSparse-$pkgver"
export CC="gcc -m32" CXX="g++ -m32" PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
- export BLAS=-lblas TBB=-ltbb SPQR_CONFIG=-DHAVE_TBB MY_METIS_LIB=/usr/lib32/libmetis.so
+ export BLAS=-lblas LAPACK=-llapack TBB=-ltbb SPQR_CONFIG=-DHAVE_TBB MY_METIS_LIB=/usr/lib32/libmetis.so
make
}
@@ -33,7 +34,7 @@ package() {
cd "${srcdir}/SuiteSparse-$pkgver"
export CC="gcc -m32" CXX="g++ -m32" PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
- export BLAS=-lblas TBB=-ltbb SPQR_CONFIG=-DHAVE_TBB MY_METIS_LIB=/usr/lib32/libmetis.so
+ export BLAS=-lblas LAPACK=-llapack TBB=-ltbb SPQR_CONFIG=-DHAVE_TBB MY_METIS_LIB=/usr/lib32/libmetis.so
make INSTALL_LIB="${pkgdir}/usr/lib32" INSTALL_INCLUDE="${pkgdir}/usr/include" install
rm -r "${pkgdir}"/usr/include
diff --git a/suitesparse-no-demo.patch b/suitesparse-no-demo.patch
index 936cdf97ac53..2f63ef142101 100644
--- a/suitesparse-no-demo.patch
+++ b/suitesparse-no-demo.patch
@@ -1,11 +1,11 @@
--- SuiteSparse-5.6.0/Makefile.orig 2019-11-05 22:37:26.086135974 +0000
+++ SuiteSparse-5.6.0/Makefile 2019-11-05 22:37:37.549632429 +0000
-@@ -12,7 +12,7 @@
- # Compile the default rules for each package
+@@ -16,7 +16,7 @@
+ # installs all libraries SuiteSparse/lib.
go: metis
( cd SuiteSparse_config && $(MAKE) )
-- ( cd Mongoose && $(MAKE) CMAKE_OPTIONS='$(CMAKE_OPTIONS)' )
-+ ( cd Mongoose && $(MAKE) library CMAKE_OPTIONS='$(CMAKE_OPTIONS)' )
+- ( cd Mongoose && $(MAKE) CMAKE_OPTIONS='$(CMAKE_OPTIONS)' )
++ ( cd Mongoose && $(MAKE) library CMAKE_OPTIONS='$(CMAKE_OPTIONS)' )
( cd AMD && $(MAKE) )
( cd BTF && $(MAKE) )
( cd CAMD && $(MAKE) )