summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBehnam Momeni2021-05-13 11:25:40 +0430
committerBehnam Momeni2021-05-13 11:25:40 +0430
commitff4319ab66769f13ff92367b70968b56e859ea78 (patch)
tree0e3380e7329ed7387cac65f2fec9b5c54535996b
parent2e83c83eba984c118365f6aa44f8083a9c01ccab (diff)
downloadaur-ff4319ab66769f13ff92367b70968b56e859ea78.tar.gz
Disable CUDA since there is no 32-bit libcudart.so file
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--flags.patch23
3 files changed, 22 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index addcfe8132b4..9dd5f76ac64f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri May 7 08:19:59 UTC 2021
+# Thu May 13 06:55:12 UTC 2021
pkgbase = lib32-suitesparse
pkgdesc = A collection of sparse matrix libraries (32-bit)
pkgver = 5.9.0
- pkgrel = 4
+ pkgrel = 5
url = http://faculty.cse.tamu.edu/davis/suitesparse.html
arch = x86_64
license = GPL
@@ -21,7 +21,7 @@ pkgbase = lib32-suitesparse
source = flags.patch
sha512sums = d0b7de23d769b4537a9deac7a7c42408f29ddaa66e2c4be2c4b6465a6e8b60f7705db8b2a8de89808208a2fdd8e6ac8e25e54a0429952b16a1b22ce2e4469475
sha512sums = 6ae782d64e01096adecef7e2ae3eee78c5a93e31493705c1a22851159c8b8560dd58acb489f5b02d8312d4488688675b3748c6c27101b9b6777928570e6e4cea
- sha512sums = e9a8b181b35546c9c4048896e1b1ff329296b6505ed15a7a5645c538d284b87fbdfd359d7fbec6dd7f1d0c092bc2b658458638acdc64aea453a8b750abf02919
+ sha512sums = cdcc06fb7b92174379f426e1bb05edc9b66029384049ea9287ef4bd304bc9a81a53c6e7995d262644dc32df03a525a928e27798c3a83cc7abd0ad106a351382c
pkgname = lib32-suitesparse
diff --git a/PKGBUILD b/PKGBUILD
index d6d87e5dada1..3a0ce412f0d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=lib32-suitesparse
_pkgbase=suitesparse
pkgver=5.9.0
-pkgrel=4
+pkgrel=5
pkgdesc="A collection of sparse matrix libraries (32-bit)"
url="http://faculty.cse.tamu.edu/davis/suitesparse.html"
arch=('x86_64')
@@ -18,7 +18,7 @@ source=($_pkgbase-$pkgver.tar.gz::"https://github.com/DrTimothyAldenDavis/SuiteS
"flags.patch")
sha512sums=('d0b7de23d769b4537a9deac7a7c42408f29ddaa66e2c4be2c4b6465a6e8b60f7705db8b2a8de89808208a2fdd8e6ac8e25e54a0429952b16a1b22ce2e4469475'
'6ae782d64e01096adecef7e2ae3eee78c5a93e31493705c1a22851159c8b8560dd58acb489f5b02d8312d4488688675b3748c6c27101b9b6777928570e6e4cea'
- 'e9a8b181b35546c9c4048896e1b1ff329296b6505ed15a7a5645c538d284b87fbdfd359d7fbec6dd7f1d0c092bc2b658458638acdc64aea453a8b750abf02919')
+ 'cdcc06fb7b92174379f426e1bb05edc9b66029384049ea9287ef4bd304bc9a81a53c6e7995d262644dc32df03a525a928e27798c3a83cc7abd0ad106a351382c')
prepare() {
cd "${srcdir}/SuiteSparse-$pkgver"
diff --git a/flags.patch b/flags.patch
index 18e5b2b5f202..ade8eac15006 100644
--- a/flags.patch
+++ b/flags.patch
@@ -1,6 +1,6 @@
-diff -ruN SuiteSparse-5.9.0/Mongoose/CMakeLists.txt SuiteSparse-5.9.0.new/Mongoose/CMakeLists.txt
---- SuiteSparse-5.9.0/Mongoose/CMakeLists.txt 2021-03-04 01:34:33.000000000 +0330
-+++ SuiteSparse-5.9.0.new/Mongoose/CMakeLists.txt 2021-04-30 18:06:24.312588249 +0430
+diff -ruN SuiteSparse-5.9.0.orig/Mongoose/CMakeLists.txt SuiteSparse-5.9.0/Mongoose/CMakeLists.txt
+--- SuiteSparse-5.9.0.orig/Mongoose/CMakeLists.txt 2021-03-04 01:34:33.000000000 +0330
++++ SuiteSparse-5.9.0/Mongoose/CMakeLists.txt 2021-05-13 11:20:57.620348766 +0430
@@ -328,7 +328,7 @@
SET(CMAKE_EXE_LINKER_FLAGS_DEBUG "--coverage -g")
elseif ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
@@ -10,9 +10,9 @@ diff -ruN SuiteSparse-5.9.0/Mongoose/CMakeLists.txt SuiteSparse-5.9.0.new/Mongoo
# Debug flags for GCC
if (CMAKE_CXX_COMPILER_VERSION VERSION_LESS "4.6")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
-diff -ruN SuiteSparse-5.9.0/SuiteSparse_config/SuiteSparse_config.mk SuiteSparse-5.9.0.new/SuiteSparse_config/SuiteSparse_config.mk
---- SuiteSparse-5.9.0/SuiteSparse_config/SuiteSparse_config.mk 2021-03-04 01:34:33.000000000 +0330
-+++ SuiteSparse-5.9.0.new/SuiteSparse_config/SuiteSparse_config.mk 2021-04-30 18:01:37.603417101 +0430
+diff -ruN SuiteSparse-5.9.0.orig/SuiteSparse_config/SuiteSparse_config.mk SuiteSparse-5.9.0/SuiteSparse_config/SuiteSparse_config.mk
+--- SuiteSparse-5.9.0.orig/SuiteSparse_config/SuiteSparse_config.mk 2021-03-04 01:34:33.000000000 +0330
++++ SuiteSparse-5.9.0/SuiteSparse_config/SuiteSparse_config.mk 2021-05-13 11:22:13.751009370 +0430
@@ -146,7 +146,7 @@
endif
endif
@@ -22,6 +22,17 @@ diff -ruN SuiteSparse-5.9.0/SuiteSparse_config/SuiteSparse_config.mk SuiteSparse
#---------------------------------------------------------------------------
# CFLAGS for the C/C++ compiler
+@@ -224,8 +224,8 @@
+ #---------------------------------------------------------------------------
+
+ # CUDA is detected automatically, and used if found. To disable CUDA,
+- # use CUDA=no
+- CUDA = auto
++ CUDA=no
++ # CUDA = auto
+
+ ifneq ($(CUDA),no)
+ CUDA_PATH = $(shell which nvcc 2>/dev/null | sed "s/\/bin\/nvcc//")
@@ -259,7 +259,6 @@
MAGMA_LIB = -L/opt/magma-2.4.0/lib/ -lmagma
NVCC = $(CUDA_PATH)/bin/nvcc