summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc Aldorasi2018-02-25 16:26:49 -0500
committerMarc Aldorasi2018-02-25 16:26:49 -0500
commit14fcb051d94b0805ef979ef9f6690d39b26f8dfd (patch)
tree01c05e9ef8e0a7c71844c7442e44ade1e107c3c4
parent12f0519d0a9d8f6773c87ef4165f6a5cdc24093a (diff)
downloadaur-lib32-swh-plugins.tar.gz
Update to 0.4.17
Follow swh-plugins and use lib32-gsm
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
-rw-r--r--mbeq_crash_fix.patch39
-rw-r--r--use_system_gsm.patch51
4 files changed, 73 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7015f08a905a..f20dd074d352 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = lib32-swh-plugins
pkgdesc = Steve Harris' LADSPA plug-ins suite
- pkgver = 0.4.15
- pkgrel = 6
+ pkgver = 0.4.17
+ pkgrel = 1
url = http://plugin.org.uk/
install = lib32-swh-plugins.install
arch = x86_64
- license = GPL
+ license = GPL2
makedepends = lib32-libxml2
makedepends = perl-xml-parser
depends = lib32-fftw
depends = lib32-ladspa
- source = http://plugin.org.uk/releases/0.4.15/swh-plugins-0.4.15.tar.gz
- source = mbeq_crash_fix.patch
- md5sums = 2fbdccef2462ea553901acd429fa3573
- md5sums = a60422c8dea95bee6f9adcdc70dff7e0
+ depends = lib32-gsm
+ source = swh-plugins-0.4.17.tar.gz::https://github.com/swh/ladspa/archive/v0.4.17.tar.gz
+ source = use_system_gsm.patch
+ sha512sums = 6b566030b43c3929ce8938648abd458efa0fea0b4916410a34b4f4fa788c45e4a6ec3f46ca435f8546179ff0c4674303db22314e1c1f1d09e5f2b71e6c5aecc7
+ sha512sums = 7080a115442d682bdad17b2bfa2694ba5f6ef53efcd214748fe26133dda6a79726f57e34819e2324d1bf0a999baf5c895cba488658cc9695d4903755dce5774f
pkgname = lib32-swh-plugins
diff --git a/PKGBUILD b/PKGBUILD
index 97852dd429fd..794822aa2f70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,49 +3,42 @@
_pkgbasename=swh-plugins
pkgname=lib32-$_pkgbasename
-pkgver=0.4.15
-pkgrel=6
+pkgver=0.4.17
+pkgrel=1
pkgdesc="Steve Harris' LADSPA plug-ins suite"
arch=('x86_64')
url="http://plugin.org.uk/"
-license=('GPL')
+license=('GPL2')
install=lib32-swh-plugins.install
-depends=('lib32-fftw' 'lib32-ladspa')
+depends=('lib32-fftw' 'lib32-ladspa' 'lib32-gsm')
makedepends=('lib32-libxml2' 'perl-xml-parser')
-source=("http://plugin.org.uk/releases/$pkgver/$_pkgbasename-$pkgver.tar.gz"
- 'mbeq_crash_fix.patch')
-md5sums=('2fbdccef2462ea553901acd429fa3573'
- 'a60422c8dea95bee6f9adcdc70dff7e0')
+source=("${_pkgbasename}-${pkgver}.tar.gz::https://github.com/swh/ladspa/archive/v${pkgver}.tar.gz"
+ 'use_system_gsm.patch')
+sha512sums=('6b566030b43c3929ce8938648abd458efa0fea0b4916410a34b4f4fa788c45e4a6ec3f46ca435f8546179ff0c4674303db22314e1c1f1d09e5f2b71e6c5aecc7'
+ '7080a115442d682bdad17b2bfa2694ba5f6ef53efcd214748fe26133dda6a79726f57e34819e2324d1bf0a999baf5c895cba488658cc9695d4903755dce5774f')
prepare() {
- cd "$srcdir/$_pkgbasename-$pkgver"
-
- # Arch64 fix;
- # -fPIC seems to be the only option
+ mv -v "${srcdir}/ladspa-${pkgver}" "${srcdir}/${_pkgbasename}-${pkgver}"
+ cd "${srcdir}/${_pkgbasename}-${pkgver}"
+ patch -Np1 -i "${srcdir}/use_system_gsm.patch"
+ autoreconf -fvi
export CFLAGS="$CFLAGS -fPIC"
export CXXFLAGS="$CFLAGS"
-
- # fix Firefox crash on x64 when
- # plugin is in use by ALSA;
- # see https://bugs.archlinux.org/task/24579
- patch -Np1 -i "$srcdir/mbeq_crash_fix.patch"
}
build() {
- cd "$srcdir/$_pkgbasename-$pkgver"
+ cd "${srcdir}/${_pkgbasename}-${pkgver}"
export CC='gcc -m32'
export CXX='g++ -m32'
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
./configure --prefix=/usr
- #sed -i 's|^plugindir = /usr/lib/ladspa$|plugindir = /usr/lib32/ladspa|' Makefile
- #sed -i 's|metadata||' Makefile
make
}
package() {
- cd "$srcdir/$_pkgbasename-$pkgver"
+ cd "${srcdir}/${_pkgbasename}-${pkgver}"
make DESTDIR="$pkgdir/" install
diff --git a/mbeq_crash_fix.patch b/mbeq_crash_fix.patch
deleted file mode 100644
index 37ddd33a910c..000000000000
--- a/mbeq_crash_fix.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff -Nru swh-plugins-0.4.15.orig/mbeq_1197.c swh-plugins-0.4.15/mbeq_1197.c
---- swh-plugins-0.4.15.orig/mbeq_1197.c 2006-08-09 01:49:15.000000000 +1000
-+++ swh-plugins-0.4.15/mbeq_1197.c 2011-06-05 10:57:17.929107102 +1000
-@@ -457,7 +457,8 @@
- #endif
-
- // Multiply the bins magnitudes by the coeficients
-- for (i = 0; i < FFT_LENGTH/2; i++) {
-+ comp[0] *= coefs[0];
-+ for (i = 1; i < FFT_LENGTH/2; i++) {
- comp[i] *= coefs[i];
- comp[FFT_LENGTH-i] *= coefs[i];
- }
-diff -Nru swh-plugins-0.4.15.orig/mbeq_1197.so.c swh-plugins-0.4.15/mbeq_1197.so.c
---- swh-plugins-0.4.15.orig/mbeq_1197.so.c 2003-10-22 02:13:40.000000000 +1000
-+++ swh-plugins-0.4.15/mbeq_1197.so.c 2011-06-05 10:57:52.265774336 +1000
-@@ -446,7 +446,8 @@
- #endif
-
- // Multiply the bins magnitudes by the coeficients
-- for (i = 0; i < FFT_LENGTH/2; i++) {
-+ comp[0] *= coefs[0];
-+ for (i = 1; i < FFT_LENGTH/2; i++) {
- comp[i] *= coefs[i];
- comp[FFT_LENGTH-i] *= coefs[i];
- }
-diff -Nru swh-plugins-0.4.15.orig/mbeq_1197.xml swh-plugins-0.4.15/mbeq_1197.xml
---- swh-plugins-0.4.15.orig/mbeq_1197.xml 2005-06-01 19:51:58.000000000 +1000
-+++ swh-plugins-0.4.15/mbeq_1197.xml 2011-06-05 10:57:39.335774121 +1000
-@@ -171,7 +171,8 @@
- #endif
-
- // Multiply the bins magnitudes by the coeficients
-- for (i = 0; i < FFT_LENGTH/2; i++) {
-+ comp[0] *= coefs[0];
-+ for (i = 1; i < FFT_LENGTH/2; i++) {
- comp[i] *= coefs[i];
- comp[FFT_LENGTH-i] *= coefs[i];
- }
diff --git a/use_system_gsm.patch b/use_system_gsm.patch
new file mode 100644
index 000000000000..d1901ad1d023
--- /dev/null
+++ b/use_system_gsm.patch
@@ -0,0 +1,51 @@
+Description: Use system-wide copies of gsm.h.
+Author: Jaromír Mikeš <mira.mikes@seznam.cz>
+Forwarded: not-needed
+
+Index: swh-plugins/gsm_1215.xml
+===================================================================
+--- swh-plugins.orig/gsm_1215.xml
++++ swh-plugins/gsm_1215.xml
+@@ -9,7 +9,7 @@
+ <code><![CDATA[
+ #include <stdlib.h>
+ #include "ladspa-util.h"
+- #include "gsm/gsm.h"
++ #include <gsm/gsm.h>
+ #include "util/biquad.h"
+
+ #define SCALE 32768.0f
+Index: swh-plugins/configure.ac
+===================================================================
+--- swh-plugins.orig/configure.ac
++++ swh-plugins/configure.ac
+@@ -143,7 +143,6 @@ AC_SUBST(LIBTOOL)
+ AC_OUTPUT([
+ Makefile
+ util/Makefile
+-gsm/Makefile
+ gverb/Makefile
+ metadata/Makefile
+ po/Makefile.in
+Index: swh-plugins/Makefile.am
+===================================================================
+--- swh-plugins.orig/Makefile.am
++++ swh-plugins/Makefile.am
+@@ -34,7 +34,7 @@ plugin_LTLIBRARIES = \
+ latency_1914.la xfade_1915.la sc4m_1916.la \
+ mbeq_1197.la pitch_scale_1193.la pitch_scale_1194.la imp_1199.la
+
+-SUBDIRS = po util gsm gverb metadata
++SUBDIRS = po util gverb metadata
+
+ # Wacky stuff to stop automake getting confused
+ EXTRA_DIST = config.rpath @top_srcdir@/*.xml @top_srcdir@/*.c @top_srcdir@/*.h \
+@@ -73,7 +73,7 @@ sc3_1427_la_LIBADD = -Lutil -ldb -lrms
+ sc4_1882_la_LIBADD = -Lutil -ldb -lrms
+ sc4m_1916_la_LIBADD = -Lutil -ldb -lrms
+ se4_1883_la_LIBADD = -Lutil -ldb -lrms
+-gsm_1215_la_LIBADD = gsm/libgsm.a
++gsm_1215_la_LIBADD = -lgsm
+ gverb_1216_la_LIBADD = -Lgverb -lgverb
+ lcr_delay_1436_la_DEPENDENCIES = util/biquad.h
+