summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYurii Kolesnykov2019-04-14 18:36:05 +0200
committerYurii Kolesnykov2019-04-14 18:36:05 +0200
commit6635e8ed6382f4c94211f7599f2bba2871f960ee (patch)
treec2873a117b5c808bc3e1570b6e013604efef31ea
parent9cf27d1f1eec34b3096f16fe3babc92a362abe7e (diff)
downloadaur-6635e8ed6382f4c94211f7599f2bba2871f960ee.tar.gz
242.104
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7f772f93582..49adaa416fca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-systemd-git
pkgdesc = system and service manager (32-bit, git version)
- pkgver = 242.44
+ pkgver = 242.104
pkgrel = 1
url = https://www.github.com/systemd/systemd
arch = x86_64
@@ -29,9 +29,7 @@ pkgbase = lib32-systemd-git
depends = systemd
provides = lib32-systemd
conflicts = lib32-systemd
- options = strip
- options = !distcc
- options = !ccache
+ options = !strip
source = git+https://github.com/systemd/systemd
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b0a344454ae5..dc18814f92b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=lib32-systemd-git
_pkgname=lib32-systemd
_pkgbasename=systemd
-pkgver=242.44
+pkgver=242.104
pkgrel=1
pkgdesc='system and service manager (32-bit, git version)'
arch=('x86_64')
@@ -19,7 +19,7 @@ makedepends=('gcc-multilib' 'git' 'gperf' 'intltool' 'lib32-acl' 'lib32-bzip2'
'lib32-curl' 'lib32-dbus' 'lib32-gcc-libs' 'lib32-glib2'
'lib32-gnutls' 'lib32-libelf' 'lib32-libidn2' 'lib32-pcre2'
'libxslt' 'meson')
-options=('strip' '!distcc' '!ccache')
+options=('!strip')
source=('git+https://github.com/systemd/systemd')
sha512sums=('SKIP')
@@ -28,10 +28,10 @@ pkgver() {
cd "$_pkgbasename"
- version="$(git describe --abbrev=0 --tags)"
- count="$(git rev-list --count ${version}..)"
- version="$(echo ${version}| sed 's/-/./')"
- printf '%s.%s' "${version#v}" "${count}"
+ local _version _count
+ _version="$(git describe --abbrev=0 --tags)"
+ _count="$(git rev-list --count ${_version}..)"
+ printf '%s.%s' "${_version#v}" "${_count}"
}
build() {
@@ -94,9 +94,9 @@ build() {
ninja -C build
}
-#check() {
-# meson test -C build
-#}
+check() {
+ meson test -C build
+}
package() {
DESTDIR="$pkgdir" ninja -C build install