summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Souza Franco2021-01-27 19:50:10 -0300
committerGabriel Souza Franco2021-01-27 19:50:10 -0300
commit0240b38f42654e8bac6a52e6bdc7395be927c138 (patch)
tree2f915a650c7370e800f9e9b8a2236e6ef5c1c7f7
parentf89dd3cfff9f1f1b06120a1fcf447cdc64a86389 (diff)
downloadaur-0240b38f42654e8bac6a52e6bdc7395be927c138.tar.gz
Update to version 1.4.13
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51d703ac0cd9..5e764d280ec3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = lib32-tkimg
- pkgdesc = This package enhances Tk, adding support for many other Image formats: BMP, XBM, XPM, GIF, PNG, JPEG, TIFF and postscript. (32-bit)
- pkgver = 1.4.7
+ pkgdesc = Provides the handling of several image formats beyond the standard formats in Tk (32-bit)
+ pkgver = 1.4.13
pkgrel = 1
- url = http://tkimg.sourceforge.net
+ url = https://wiki.tcl-lang.org/page/Img
arch = x86_64
license = BSD
depends = lib32-zlib
@@ -12,8 +12,8 @@ pkgbase = lib32-tkimg
depends = lib32-tcl
depends = lib32-tk
depends = tcllib
- source = http://downloads.sourceforge.net/tkimg/1.4/Img-Source-1.4.7.tar.gz
- sha1sums = c8131096488f42fbb143aee41e3b4878eaa17397
+ source = http://downloads.sourceforge.net/tkimg/1.4/Img-1.4.13-Source.tar.gz
+ sha1sums = b35ddb2aad1b9f513f3a4f1eeaf3b7e1b681fc80
pkgname = lib32-tkimg
diff --git a/PKGBUILD b/PKGBUILD
index 2dd4ffc9e648..2fcfb781ea6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,28 @@
# Contributor: kotyz <kotyz.king@gmail.com>
pkgname=lib32-tkimg
-pkgver=1.4.7
+pkgver=1.4.13
pkgrel=1
-pkgdesc="This package enhances Tk, adding support for many other Image formats: BMP, XBM, XPM, GIF, PNG, JPEG, TIFF and postscript. (32-bit)"
-url="http://tkimg.sourceforge.net"
+pkgdesc='Provides the handling of several image formats beyond the standard formats in Tk (32-bit)'
+url='https://wiki.tcl-lang.org/page/Img'
arch=('x86_64')
license=('BSD')
depends=('lib32-zlib' 'lib32-libjpeg' 'lib32-libpng' 'lib32-libtiff' 'lib32-tcl' 'lib32-tk' 'tcllib')
-source=(http://downloads.sourceforge.net/tkimg/${pkgver%.*}/Img-Source-$pkgver.tar.gz)
-sha1sums=('c8131096488f42fbb143aee41e3b4878eaa17397')
+source=(http://downloads.sourceforge.net/tkimg/${pkgver%.*}/Img-$pkgver-Source.tar.gz)
+sha1sums=('b35ddb2aad1b9f513f3a4f1eeaf3b7e1b681fc80')
build() {
- cd "$srcdir/Img-Source-$pkgver"
+ cd "$srcdir/Img-$pkgver"
export CC='gcc -m32'
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
- ./configure --prefix=/usr --libdir=/usr/lib32
+ ./configure --prefix=/usr --libdir=/usr/lib32 --enable-threads
make
}
package() {
- cd "$srcdir/Img-Source-$pkgver"
+ cd "$srcdir/Img-$pkgver"
make INSTALL_ROOT="$pkgdir" install
rm -rf "$pkgdir/usr/"{include,share}