summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Ostuni2016-08-09 16:08:31 +0200
committerDario Ostuni2016-08-09 16:08:31 +0200
commit08afcb0b6abc9c7f2d8dd1db432ce36073d6e2fc (patch)
treeafe00bb989975c45ec1387044810825b36503451
downloadaur-08afcb0b6abc9c7f2d8dd1db432ce36073d6e2fc.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..92a803982f71
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Tue Aug 9 14:08:19 UTC 2016
+pkgbase = lib32-tslib
+ pkgdesc = Touchscreen Access Library (32-bit)
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/kergoth/tslib
+ arch = x86_64
+ license = GPL2
+ depends = lib32-glibc
+ source = https://github.com/kergoth/tslib/releases/download/1.1/tslib-1.1.tar.xz
+ sha1sums = f4a2e069517766bc9394c889b240a785ab0fd6a4
+
+pkgname = lib32-tslib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1c1da7f83a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Dario Ostuni <another.code.996@gmail.com>
+
+pkgname=lib32-tslib
+_pkgname=tslib
+pkgver=1.1
+pkgrel=1
+pkgdesc="Touchscreen Access Library (32-bit)"
+arch=(x86_64)
+url="https://github.com/kergoth/tslib"
+license=(GPL2)
+depends=(lib32-glibc)
+makedepends=()
+source=("https://github.com/kergoth/tslib/releases/download/$pkgver/$_pkgname-$pkgver.tar.xz")
+sha1sums=('f4a2e069517766bc9394c889b240a785ab0fd6a4')
+
+build() {
+ cd $_pkgname-$pkgver
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ ./autogen.sh
+ ./configure --prefix=/usr --libdir=/usr/lib32 --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ rm -rf "${pkgdir}"/usr/{include,share,bin}
+ rm -rf "${pkgdir}"/etc
+}