summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsolaraquarion2016-11-03 12:12:08 -0400
committersolaraquarion2016-11-03 12:12:08 -0400
commitcfd63356245d7a182c2b7490531753389f6b16fa (patch)
tree02f0bd9f1f291bcf30ecd6cf928d73981ef5c0b8
downloadaur-cfd63356245d7a182c2b7490531753389f6b16fa.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b02eb374155
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Nov 3 16:12:04 UTC 2016
+pkgbase = lib32-vo-aacenc
+ pkgdesc = VisualOn Advanced Audio Coding (AAC) encoder
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = http://sourceforge.net/projects/opencore-amr/
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ depends = glibc
+ options = !emptydirs
+ options = !libtool
+ source = http://heanet.dl.sourceforge.net/project/opencore-amr/vo-aacenc/vo-aacenc-0.1.3.tar.gz
+ sha256sums = e51a7477a359f18df7c4f82d195dab4e14e7414cbd48cf79cc195fc446850f36
+
+pkgname = lib32-vo-aacenc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3041acf2569d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Justin Dray <justin@dray.be>
+# Contributor: David Roheim <david dot roheim at gmail dot com>
+# Contributor: Leonard de Ruijter <leonard@aur.archlinux.org>
+# Contributor: DrZaius <lou[at]fakeoutdoorsman[dot]com>
+pkgname=lib32-vo-aacenc
+_pkgname=vo-aacenc
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="VisualOn Advanced Audio Coding (AAC) encoder"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/opencore-amr/"
+license=('APACHE')
+depends=('glibc')
+options=('!emptydirs' '!libtool')
+source=(http://heanet.dl.sourceforge.net/project/opencore-amr/vo-aacenc/$_pkgname-$pkgver.tar.gz)
+sha256sums=('e51a7477a359f18df7c4f82d195dab4e14e7414cbd48cf79cc195fc446850f36')
+
+build() {
+ export CC="clang -m32"
+ export CXX="clang++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ cd "$srcdir/$_pkgname-$pkgver"
+ ./configure --prefix=/usr \
+ --libdir=/usr/lib32
+ make
+}
+
+package () {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ rm -rf $pkgdir/usr/include
+}
+