summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchdevlab2024-01-31 21:29:03 -0500
committerarchdevlab2024-01-31 21:29:03 -0500
commitf337457a3b7438f70818facf84a7671d9a0a3c64 (patch)
tree0f21a2b33c76b094458342c6c1fe473f9eab8567
parent7c42eb9aae489e244f489caef41f76e682633048 (diff)
downloadaur-f337457a3b7438f70818facf84a7671d9a0a3c64.tar.gz
fix and update pkgver func
-rw-r--r--PKGBUILD3
1 files changed, 1 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7d6865b3fde9..569449439f44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,8 +17,7 @@ source=(git+https://github.com/KhronosGroup/Vulkan-Loader.git)
pkgver(){
cd "${srcdir}"/Vulkan-Loader
- # cutting off 'foo-' prefix that presents in the git tag
- git describe --long --tags --abbrev=7 --exclude sdk-* --exclude vulkan-* | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags --abbrev=7 --match='v*' | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build(){