summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchdevlab2024-01-31 21:34:44 -0500
committerarchdevlab2024-01-31 21:34:44 -0500
commitc157df33fbfa8eb51d4b3700e413a1a68241c4c2 (patch)
tree1bd420d70380e27bebcda0a8abdda0f0d999be99
parent9c1f91c42f6e4c96c84ba589aca1bd3539109346 (diff)
downloadaur-c157df33fbfa8eb51d4b3700e413a1a68241c4c2.tar.gz
update pkgver func
-rw-r--r--PKGBUILD3
1 files changed, 1 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c04a76aa31e0..d16ff3338347 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,8 +17,7 @@ source=(git+https://github.com/KhronosGroup/Vulkan-Utility-Libraries.git)
pkgver(){
cd "${srcdir}"/Vulkan-Utility-Libraries
- # cutting off 'foo-' prefix that presents in the git tag
- git describe --long --tags --abbrev=7 --exclude sdk-* --exclude vulkan-* | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags --abbrev=7 --match='v*' | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build(){