summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-06-28 14:54:47 -0400
committerVincent Grande2021-06-28 14:54:47 -0400
commit20cffdd5d1000dd54692d69b5331d1487875a2c5 (patch)
treecb636a66d2fb4b68331802535af1c216e30a921e
parentcb08740fc87d286ed24ee0b4880228afde6420aa (diff)
downloadaur-20cffdd5d1000dd54692d69b5331d1487875a2c5.tar.gz
meson
-rwxr-xr-x[-rw-r--r--].SRCINFO3
-rwxr-xr-xPKGBUILD26
2 files changed, 9 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d4f8e10c073..2b649dbeb2ed 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-wayland-git
pkgdesc = A computer display server protocol
- pkgver = 1.17.0.r18.g6908c8c
+ pkgver = 1.19.0.r23.g3e897fa
pkgrel = 1
url = https://wayland.freedesktop.org/
arch = x86_64
@@ -17,4 +17,3 @@ pkgbase = lib32-wayland-git
sha256sums = SKIP
pkgname = lib32-wayland-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3c7883b3a7e2..633f4da10857 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgbase=lib32-wayland-git
pkgname=('lib32-wayland-git')
-pkgver=1.17.0.r18.g6908c8c
+pkgver=1.19.0.r23.g3e897fa
pkgrel=1
pkgdesc='A computer display server protocol'
arch=('x86_64')
@@ -26,27 +26,17 @@ pkgver() {
}
build() {
- cd wayland
-
- export CC='gcc -m32'
- export PKG_CONFIG_PATH=/usr/lib32/pkgconfig
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG="i686-pc-linux-gnu-pkg-config"
- ./autogen.sh \
- --prefix='/usr' \
- --libdir=/usr/lib32 \
- --disable-documentation \
- --disable-static
-
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
-
- make
+ meson build wayland --buildtype='release' --prefix='/usr' --libdir=/usr/lib32 -D documentation=false
}
package() {
-
- make DESTDIR="${pkgdir}" -C wayland install
+ DESTDIR="$pkgdir" ninja -C build install
rm -rf "${pkgdir}"/usr/{bin,include,share}
- install -dm 755 "${pkgdir}"/usr/share/licenses
- ln -s wayland "${pkgdir}"/usr/share/licenses/lib32-wayland
+# install -dm 755 "${pkgdir}"/usr/share/licenses
+# ln -s wayland "${pkgdir}"/usr/share/licenses/lib32-wayland
}