summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorheavysink2020-09-24 21:22:31 -0400
committerheavysink2020-09-24 21:22:31 -0400
commit72aed2b2c5c0f17f8c7988701119a02b09ea5d6f (patch)
tree8629546e08e7f81d851258a61849eec8c490f214
downloadaur-72aed2b2c5c0f17f8c7988701119a02b09ea5d6f.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD83
-rw-r--r--make-abicheck-non-fatal.patch16
3 files changed, 126 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0535f90d0cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = lib32-wxgtk3
+ pkgdesc = GTK+ implementation of wxWidgets API for GUI
+ pkgver = 3.0.5.1
+ pkgrel = 2
+ url = https://wxwidgets.org
+ arch = x86_64
+ license = custom:wxWindows
+ makedepends = git
+ makedepends = lib32-glu
+ depends = lib32-expat
+ depends = lib32-gtk3
+ depends = lib32-libjpeg
+ depends = lib32-libpng
+ depends = lib32-libsm
+ depends = lib32-libtiff
+ depends = lib32-zlib
+ depends = wxgtk3
+ provides = lib32-wxgtk
+ conflicts = lib32-wxgtk
+ replaces = lib32-wxgtk
+ source = git+https://github.com/wxWidgets/wxWidgets.git#tag=db9378c1d32e84cf7ca4453932df259471d67dc9
+ source = make-abicheck-non-fatal.patch
+ sha256sums = SKIP
+ sha256sums = d4c2d070a06eb63f0a018c8cf687589e5ffdec601225b4d16a268ffe390fb58b
+
+pkgname = lib32-wxgtk3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ba74b7a3854
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,83 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=lib32-wxgtk3
+pkgver=3.0.5.1
+pkgrel=2
+pkgdesc='GTK+ implementation of wxWidgets API for GUI'
+arch=(x86_64)
+url=https://wxwidgets.org
+license=(custom:wxWindows)
+depends=(
+ lib32-expat
+ lib32-gtk3
+ lib32-libjpeg
+ lib32-libpng
+ lib32-libsm
+ lib32-libtiff
+ lib32-zlib
+ wxgtk3
+)
+makedepends=(
+ git
+ lib32-glu
+)
+conflicts=(lib32-wxgtk)
+provides=(lib32-wxgtk)
+replaces=(lib32-wxgtk)
+_tag=db9378c1d32e84cf7ca4453932df259471d67dc9
+source=(
+ git+https://github.com/wxWidgets/wxWidgets.git#tag=${_tag}
+ make-abicheck-non-fatal.patch
+)
+sha256sums=(
+ SKIP
+ d4c2d070a06eb63f0a018c8cf687589e5ffdec601225b4d16a268ffe390fb58b
+)
+
+prepare() {
+ cd wxWidgets
+
+ patch -Np1 -i ../make-abicheck-non-fatal.patch
+
+ ./autogen.sh
+}
+
+build() {
+ cd wxWidgets
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH=/usr/lib32/pkgconfig
+ export CFLAGS="-I/usr/include/libtiff32 $CFLAGS"
+ export CXXFLAGS="-I/usr/include/libtiff32 $CXXFLAGS"
+
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib32 \
+ --enable-graphics_ctx \
+ --enable-unicode \
+ --disable-mediactrl \
+ --disable-precomp-headers \
+ --disable-webview \
+ --with-gtk=3 \
+ --with-lib{jpeg,png,tiff}=sys \
+ --with-opengl \
+ --with-regex=builtin \
+ --without-libnotify
+ make
+ make -C locale allmo
+}
+
+package() {
+ make DESTDIR="${pkgdir}" -C wxWidgets install
+ rm -rf "${pkgdir}"/usr/{bin/{wx-config,wxrc},include,share}
+ mv "${pkgdir}"/usr/bin/wxrc{,32}-3.0
+ ln -s /usr/bin/wxrc32-3.0 "${pkgdir}"/usr/bin/wxrc32
+ ln -s /usr/lib32/wx/config/gtk3-unicode-3.0 "${pkgdir}"/usr/bin/wx-config32
+
+ install -dm 755 "${pkgdir}"/usr/share/licenses
+ ln -s wxgtk3 "${pkgdir}"/usr/share/licenses/lib32-wxgtk3
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/make-abicheck-non-fatal.patch b/make-abicheck-non-fatal.patch
new file mode 100644
index 000000000000..90085f02c8ad
--- /dev/null
+++ b/make-abicheck-non-fatal.patch
@@ -0,0 +1,16 @@
+diff -up wxGTK-2.8.12/src/common/appbase.cpp.abicheck wxGTK-2.8.12/src/common/appbase.cpp
+--- wxGTK-2.8.12/src/common/appbase.cpp.abicheck 2015-03-12 17:15:18.000000000 +0100
++++ wxGTK-2.8.12/src/common/appbase.cpp 2015-03-12 17:15:57.000000000 +0100
+@@ -424,10 +424,7 @@ bool wxAppConsole::CheckBuildOptions(con
+ msg.Printf(_T("Mismatch between the program and library build versions detected.\nThe library used %s,\nand %s used %s."),
+ lib.c_str(), progName.c_str(), prog.c_str());
+
+- wxLogFatalError(msg.c_str());
+-
+- // normally wxLogFatalError doesn't return
+- return false;
++ wxLogWarning(msg.c_str());
+ }
+ #undef wxCMP
+
+