summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororumin2017-07-08 22:18:42 +0900
committerorumin2017-07-08 22:18:42 +0900
commit7c43a77dc388de39230391352c59e7ca29da15db (patch)
treeb50f2c18a4ca0884ed217402a775b43c44d7fdd5
downloadaur-7c43a77dc388de39230391352c59e7ca29da15db.tar.gz
initial commit
-rw-r--r--.SRCINFO57
-rw-r--r--PKGBUILD58
2 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba15cefaf7db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,57 @@
+pkgbase = lib32-xine-lib
+ pkgdesc = A multimedia playback engine (32-bit)
+ pkgver = 1.2.8
+ pkgrel = 1
+ url = http://www.xine-project.org
+ arch = x86_64
+ license = LGPL
+ license = GPL
+ makedepends = lib32-wavpack
+ makedepends = lib32-faad2
+ makedepends = lib32-libmng
+ makedepends = lib32-imagemagick
+ makedepends = lib32-mesa
+ makedepends = lib32-libmodplug
+ makedepends = lib32-vcdimager
+ makedepends = lib32-jack
+ makedepends = lib32-aalib
+ makedepends = lib32-libdca
+ makedepends = lib32-a52dec
+ makedepends = lib32-libmad
+ makedepends = lib32-libdvdnav
+ makedepends = lib32-libmpcdec
+ makedepends = lib32-libcaca
+ makedepends = lib32-libbluray
+ makedepends = lib32-libvdpau
+ makedepends = lib32-glu
+ makedepends = lib32-gdk-pixbuf2
+ makedepends = lib32-sdl
+ makedepends = lib32-smbclient
+ depends = lib32-libxvmc
+ depends = lib32-ffmpeg
+ depends = lib32-libxinerama
+ depends = xine-lib
+ optdepends = imagemagick: for using the imagemagick plugin
+ optdepends = jack: for using the jack plugin
+ optdepends = vcdimager: for using the vcd plugin
+ optdepends = glu: for using the opengl plugin
+ optdepends = wavpack: for using the wavpack plugin
+ optdepends = faad2: for using the faad plugin
+ optdepends = libmng: for using the mng plugin
+ optdepends = aalib: for using the aalib plugin
+ optdepends = libmodplug: for using the modplug plugin
+ optdepends = libdca: for using the dca plugin
+ optdepends = a52dec: for using the a52 plugin
+ optdepends = libmad: for using the mp3 plugin
+ optdepends = libdvdnav: for using the dvd plugin
+ optdepends = libmpcdec: for using the musepack plugin
+ optdepends = libcaca: for using the caca plugin
+ optdepends = libbluray: for using the bluray plugin
+ optdepends = libvdpau: for using the VDPAU plugin
+ optdepends = smbclient: for using the samba plugin
+ optdepends = gdk-pixbuf2: for using the gdk-pixbuf plugin
+ source = https://xine-lib.alioth.debian.org/releases/xine-lib-1.2.8.tar.xz
+ sha1sums = f20115ddfced42d51feb159393607b17e6f2bdc1
+
+pkgname = lib32-xine-lib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d4e8aeb964f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: orumin <dev at orum.in>
+
+pkgname=lib32-xine-lib
+_basename=xine-lib
+pkgver=1.2.8
+pkgrel=1
+pkgdesc="A multimedia playback engine (32-bit)"
+arch=('x86_64')
+url="http://www.xine-project.org"
+license=('LGPL' 'GPL')
+depends=('lib32-libxvmc' 'lib32-ffmpeg' 'lib32-libxinerama' 'xine-lib')
+makedepends=('lib32-wavpack' 'lib32-faad2' 'lib32-libmng' 'lib32-imagemagick'
+ 'lib32-mesa' 'lib32-libmodplug' 'lib32-vcdimager' 'lib32-jack'
+ 'lib32-aalib' 'lib32-libdca' 'lib32-a52dec' 'lib32-libmad' 'lib32-libdvdnav'
+ 'lib32-libmpcdec' 'lib32-libcaca' 'lib32-libbluray' 'lib32-libvdpau'
+ 'lib32-glu' 'lib32-gdk-pixbuf2' 'lib32-sdl' 'lib32-smbclient')
+optdepends=('imagemagick: for using the imagemagick plugin' \
+ 'jack: for using the jack plugin' \
+ 'vcdimager: for using the vcd plugin' \
+ 'glu: for using the opengl plugin' \
+ 'wavpack: for using the wavpack plugin' \
+ 'faad2: for using the faad plugin' \
+ 'libmng: for using the mng plugin' \
+ 'aalib: for using the aalib plugin' \
+ 'libmodplug: for using the modplug plugin' \
+ 'libdca: for using the dca plugin' \
+ 'a52dec: for using the a52 plugin' \
+ 'libmad: for using the mp3 plugin' \
+ 'libdvdnav: for using the dvd plugin' \
+ 'libmpcdec: for using the musepack plugin' \
+ 'libcaca: for using the caca plugin' \
+ 'libbluray: for using the bluray plugin' \
+ 'libvdpau: for using the VDPAU plugin' \
+ 'smbclient: for using the samba plugin' \
+ 'gdk-pixbuf2: for using the gdk-pixbuf plugin')
+source=(https://xine-lib.alioth.debian.org/releases/xine-lib-$pkgver.tar.xz)
+sha1sums=('f20115ddfced42d51feb159393607b17e6f2bdc1')
+
+build() {
+ cd ${_basename}-${pkgver}
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./configure --prefix=/usr --with-wavpack --enable-vdpau --with-external-dvdnav \
+ --build=i686-pc-linux-gnu --libdir=/usr/lib32 \
+ --disable-optimizations
+ make
+}
+
+package() {
+ cd ${_basename}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ rm -r "${pkgdir}"/usr/bin
+ rm -r "${pkgdir}"/usr/include
+ rm -r "${pkgdir}"/usr/share
+}