summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorllde2018-09-09 22:34:27 +0200
committerllde2018-09-09 22:34:27 +0200
commit37b8b4687f9542f3e3edb08a6987aa272c0c2185 (patch)
treec9f01d04b3f77bc2b8adc3e92a64aea0cfd309ba
parent162ec237a068a0cd01dcb9977187f4df2160ce82 (diff)
downloadaur-37b8b4687f9542f3e3edb08a6987aa272c0c2185.tar.gz
Fixed builds on environment with -jn with n != 1 in MAKEFLAGS. Added forgot depend xmlto
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f8930f9edad..fcd266657360 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-zbar
pkgdesc = Application and library for reading bar codes from various sources. 32bit libraries only version
pkgver = 0.20
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/procxx/zbar
arch = x86_64
license = LGPL
@@ -11,6 +11,7 @@ pkgbase = lib32-zbar
makedepends = lib32-gtk2
makedepends = pygtk
makedepends = lib32-v4l-utils
+ makedepends = xmlto
depends = zbar
source = zbar-0.20.tar.gz::https://github.com/procxx/zbar/archive/0.20.tar.gz
source = imagemagick7.patch
diff --git a/PKGBUILD b/PKGBUILD
index e2b98249bca6..81be66a426ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,13 @@
_pkgname=zbar
pkgname=lib32-zbar
pkgver=0.20
-pkgrel=1
+pkgrel=2
pkgdesc="Application and library for reading bar codes from various sources. 32bit libraries only version"
arch=('x86_64')
url="https://github.com/procxx/zbar"
license=('LGPL')
depends=('zbar')
-makedepends=('lib32-imagemagick' 'lib32-libxv' 'lib32-python2' 'lib32-gtk2' 'pygtk' 'lib32-v4l-utils')
+makedepends=('lib32-imagemagick' 'lib32-libxv' 'lib32-python2' 'lib32-gtk2' 'pygtk' 'lib32-v4l-utils' 'xmlto')
source=("$_pkgname-$pkgver.tar.gz::https://github.com/procxx/zbar/archive/$pkgver.tar.gz"
imagemagick7.patch)
sha512sums=('b013dc5f72f910e8e0dc73de1705684f76e5cb5b2026d48d3e149d3e8b46afdf273d06f32738c588c272218e95b5cd39d3c0b8be4eb9be17553504a13b11c144'
@@ -38,14 +38,14 @@ build() {
PYTHON="/usr/bin/python2" \
./configure --prefix=/usr --libdir=/usr/lib32 --without-qt --without-gtk CFLAGS="$CFLAGS -DNDEBUG"
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
+ make -j1
}
package() {
cd zbar-$pkgver
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install -j1
rm -Rf "$pkgdir"/usr/lib32/*.a \
"$pkgdir"/usr/include/ \