summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorllde2019-11-28 23:05:52 +0100
committerllde2019-11-28 23:05:52 +0100
commit8a7320cbe2451f9a960fe4ed1e8a751b075e1623 (patch)
treee49f401d3d0e97e21648dbea26986dff70e4a352
parent686e8b4aa9be1ec191d92558e23d10a52ab38e49 (diff)
downloadaur-8a7320cbe2451f9a960fe4ed1e8a751b075e1623.tar.gz
Update to 0.23, add some missing dependancies, remove python2 bindings, remove an old workaround that seems uneccessary now
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD24
-rw-r--r--imagemagick7.patch22
3 files changed, 20 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20e6c2824e94..c787f1934c33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,20 @@
pkgbase = lib32-zbar
pkgdesc = Application and library for reading bar codes from various sources. 32bit libraries only version
- pkgver = 0.22
+ pkgver = 0.23
pkgrel = 1
url = https://github.com/procxx/zbar
arch = x86_64
license = LGPL
- makedepends = lib32-imagemagick
- makedepends = lib32-libxv
- makedepends = lib32-python2
- makedepends = lib32-gtk2
- makedepends = pygtk
- makedepends = lib32-v4l-utils
+ makedepends = docbook-xsl
makedepends = xmlto
depends = zbar
- source = zbar-0.22.tar.gz::https://github.com/mchehab/zbar/archive/0.22.tar.gz
- source = imagemagick7.patch
- sha512sums = bef1078f7fe0c943e2ca7348f45e3bb5744e807c5135051fccf2c4499d52515558e98f61620e2ef2c993f35b8104d886d0639b7f0e6f8979caa5dcc49df7c931
- sha512sums = 43987414a6432b9e7da329f5a416f389d29bfc3417a6edc65a46b2677ade7dbb8c150df90c8b42464a6cb17c4732509fb8d3672387dafe9fd17a5def78a5ef63
+ depends = lib32-imagemagick
+ depends = lib32-v4l-utils
+ depends = lib32-dbus
+ depends = lib32-libsm
+ depends = lib32-libxv
+ source = zbar-0.23.tar.gz::https://github.com/mchehab/zbar/archive/0.23.tar.gz
+ sha512sums = bc2667a2a5a5f2e9fd3f39e57bf1d7f860b20a0b5faffc38791d222a6ff0414aff880295ce5ccb92acce7250503f2a7f48ac12651cf82cfb1933b302da26e393
pkgname = lib32-zbar
diff --git a/PKGBUILD b/PKGBUILD
index d7527fa97e90..266935440802 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,22 +6,20 @@
# Mantainer: Lorenzo Ferrillo <lorenzofer at live dot it>
_pkgname=zbar
pkgname=lib32-zbar
-pkgver=0.22
+pkgver=0.23
pkgrel=1
pkgdesc="Application and library for reading bar codes from various sources. 32bit libraries only version"
arch=('x86_64')
url="https://github.com/procxx/zbar"
license=('LGPL')
-depends=('zbar')
-makedepends=('lib32-imagemagick' 'lib32-libxv' 'lib32-python2' 'lib32-gtk2' 'pygtk' 'lib32-v4l-utils' 'xmlto')
+depends=('zbar' 'lib32-imagemagick' 'lib32-v4l-utils' 'lib32-dbus' 'lib32-libsm' 'lib32-libxv')
+makedepends=('docbook-xsl' 'xmlto')
source=("$_pkgname-$pkgver.tar.gz::https://github.com/mchehab/zbar/archive/$pkgver.tar.gz"
- imagemagick7.patch)
-sha512sums=('bef1078f7fe0c943e2ca7348f45e3bb5744e807c5135051fccf2c4499d52515558e98f61620e2ef2c993f35b8104d886d0639b7f0e6f8979caa5dcc49df7c931'
- '43987414a6432b9e7da329f5a416f389d29bfc3417a6edc65a46b2677ade7dbb8c150df90c8b42464a6cb17c4732509fb8d3672387dafe9fd17a5def78a5ef63')
-
+)
+sha512sums=('bc2667a2a5a5f2e9fd3f39e57bf1d7f860b20a0b5faffc38791d222a6ff0414aff880295ce5ccb92acce7250503f2a7f48ac12651cf82cfb1933b302da26e393'
+)
prepare() {
cd zbar-$pkgver
- patch -p1 -i ../imagemagick7.patch
autoreconf -vfi
}
@@ -30,21 +28,21 @@ build() {
export CC="gcc -m32"
export CXX="g++ -m32"
export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
- export PYTHON='/usr/bin/python2-32'
- export PYTHON_CONFIG='/usr/bin/python2-32-config'
+ #export PYTHON='/usr/bin/python2-32'
+ #export PYTHON_CONFIG='/usr/bin/python2-32-config'
#PKG_CONFIG_PATH="/usr/lib32/imagemagick6/pkgconfig"
- ./configure --prefix=/usr --libdir=/usr/lib32 --without-qt --without-gtk CFLAGS="$CFLAGS -DNDEBUG"
+ ./configure --prefix=/usr --libdir=/usr/lib32 --without-python --without-qt --without-gtk CFLAGS="$CFLAGS -DNDEBUG"
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make -j1
+ make
}
package() {
cd zbar-$pkgver
- make DESTDIR="$pkgdir" install -j1
+ make DESTDIR="$pkgdir" install
rm -Rf "$pkgdir"/usr/lib32/*.a \
"$pkgdir"/usr/include/ \
diff --git a/imagemagick7.patch b/imagemagick7.patch
deleted file mode 100644
index 40bd7d74ae08..000000000000
--- a/imagemagick7.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- zbar-0.10/configure.ac~ 2016-12-20 09:17:33.000000000 +0100
-+++ zbar-0.10/configure.ac 2016-12-20 09:21:38.906665127 +0100
-@@ -333,7 +333,7 @@
- dnl double check ImageMagick install (bug #2582232)
- CPPFLAGS_save="$CPPFLAGS"
- CPPFLAGS="$CPPFLAGS $MAGICK_CFLAGS"
-- AC_CHECK_HEADER([wand/MagickWand.h],
-+ AC_CHECK_HEADER([MagickWand/MagickWand.h],
- [have_IM="yes"],
- [have_IM="broken"])
- CPPFLAGS="$CPPFLAGS_save"])])
---- zbar-0.10/zbarimg/zbarimg.c.orig 2016-12-20 09:18:15.924187996 +0100
-+++ zbar-0.10/zbarimg/zbarimg.c 2016-12-20 09:20:27.679129140 +0100
-@@ -44,7 +44,7 @@
- #endif
-
- #ifdef HAVE_IMAGEMAGICK
--# include <wand/MagickWand.h>
-+# include <MagickWand/MagickWand.h>
-
- /* ImageMagick frequently changes API names - just use the original
- * (more stable?) names to match GraphicsMagick