summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlorenzo2017-08-24 20:34:58 +0200
committerlorenzo2017-08-24 20:34:58 +0200
commita4b6ffd797a0380c04051c0a9bb0b94e3ce59566 (patch)
treeeb420284ced212a39aa4858eae595b28070ac461
downloadaur-a4b6ffd797a0380c04051c0a9bb0b94e3ce59566.tar.gz
First version of the lib32-zbar package.
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD46
-rw-r--r--v4l1.patch25
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..affb97bae980
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = lib32-zbar
+ pkgdesc = Application and library for reading bar codes from various sources. 32bit libraries only version
+ pkgver = 0.10
+ pkgrel = 1
+ url = http://zbar.sourceforge.net/
+ arch = x86_64
+ license = LGPL
+ depends = lib32-imagemagick
+ depends = lib32-libxv
+ depends = lib32-python2
+ depends = lib32-gtk2
+ depends = pygtk
+ depends = lib32-v4l-utils
+ optdepends = lib32-qt4: for libzbarqt
+ provides = zbar-gtk=0.10
+ provides = zbar-qt=0.10
+ conflicts = zbar-gtk
+ conflicts = zbar-qt
+ source = http://downloads.sourceforge.net/project/zbar/zbar/0.10/zbar-0.10.tar.bz2
+ source = v4l1.patch
+ md5sums = 0fd61eb590ac1bab62a77913c8b086a5
+ md5sums = SKIP
+
+pkgname = lib32-zbar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8aa6135c0381
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+
+# Contributor: Felix Yan <felixonmars@gmail.com>
+# Contributor: Marti Raudsepp <marti@juffo.org>
+# Contributor: Radu Andries <admiral0@tuxfamily.org>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
+# Mantainer: Lorenzo Ferrillo <lorenzofer at live dot it>
+pkgname=lib32-zbar
+pkgver=0.10
+pkgrel=1
+pkgdesc="Application and library for reading bar codes from various sources. 32bit libraries only version"
+arch=('x86_64')
+url="http://zbar.sourceforge.net/"
+license=('LGPL')
+depends=('lib32-imagemagick' 'lib32-libxv' 'lib32-python2' 'lib32-gtk2' 'pygtk' 'lib32-v4l-utils')
+makedepends=()
+conflicts=('zbar-gtk' 'zbar-qt')
+provides=("zbar-gtk=$pkgver" "zbar-qt=$pkgver")
+optdepends=('lib32-qt4: for libzbarqt')
+source=("http://downloads.sourceforge.net/project/zbar/zbar/$pkgver/zbar-$pkgver.tar.bz2"
+ v4l1.patch)
+md5sums=('0fd61eb590ac1bab62a77913c8b086a5'
+ 'SKIP')
+
+prepare() {
+ cd zbar-$pkgver
+ patch -p1 -i ../v4l1.patch
+}
+
+build() {
+ cd zbar-$pkgver
+ export CC="${CC} -m32"
+ export CXX="${CXX} -m32"
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+ export PYTHON='/usr/bin/python2-32'
+ export PYTHON_CONFIG='/usr/bin/python2-32-config'
+
+ ./configure --prefix=/usr --without-qt --with-gtk CFLAGS="$CFLAGS -DNDEBUG"
+ make
+}
+
+package() {
+ cd zbar-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/v4l1.patch b/v4l1.patch
new file mode 100644
index 000000000000..2d87d411d483
--- /dev/null
+++ b/v4l1.patch
@@ -0,0 +1,25 @@
+Thanks to Andy Weidenbaum <archbaum@gmail.com> for providing this patch!
+
+--- ./zbar/video/v4l1.c 2013-03-06 23:24:22.996336417 -0800
++++ ./zbar/video/v4l1.c 2013-03-06 23:29:29.789662369 -0800
+@@ -41,7 +41,7 @@
+ #ifdef HAVE_SYS_MMAN_H
+ # include <sys/mman.h>
+ #endif
+-#include <linux/videodev.h>
++#include <libv4l1-videodev.h>
+
+ #include "video.h"
+ #include "image.h"
+--- ./configure 2009-10-23 11:17:24.000000000 -0700
++++ ./configure 2013-03-06 23:47:33.902966990 -0800
+@@ -18709,7 +18709,7 @@
+ if test "x$enable_video" != "xno"; then
+ if test "x$win32" = "xno"; then
+
+-for ac_header in linux/videodev.h
++for ac_header in libv4l1-videodev.h
+ do
+ as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ if { as_var=$as_ac_Header; eval "test \"\${$as_var+set}\" = set"; }; then
+