summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororumin2017-07-08 14:53:13 +0900
committerorumin2017-07-08 14:53:13 +0900
commit899795225665a45b55e7362b2e5ed5f186ca1586 (patch)
tree05b01ed9eb636e24dcab238803b4a812cbf3559a
downloadaur-899795225665a45b55e7362b2e5ed5f186ca1586.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..355bc8a97fd5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lib32-zvbi
+ pkgdesc = VBI capture and decoding library
+ pkgver = 0.2.35
+ pkgrel = 1
+ url = http://zapping.sourceforge.net/cgi-bin/view/ZVBI/WebHome
+ arch = x86_64
+ license = GPL
+ depends = lib32-libpng
+ depends = lib32-libx11
+ depends = zvbi
+ source = http://downloads.sourceforge.net/sourceforge/zapping/zvbi-0.2.35.tar.bz2
+ md5sums = 95e53eb208c65ba6667fd4341455fa27
+
+pkgname = lib32-zvbi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0c4243174f72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: orumin <dev at orum.in>
+
+pkgname=lib32-zvbi
+_basename=zvbi
+pkgver=0.2.35
+pkgrel=1
+pkgdesc="VBI capture and decoding library"
+url="http://zapping.sourceforge.net/cgi-bin/view/ZVBI/WebHome"
+arch=('x86_64')
+depends=('lib32-libpng' 'lib32-libx11' 'zvbi')
+license=('GPL')
+source=(http://downloads.sourceforge.net/sourceforge/zapping/${_basename}-${pkgver}.tar.bz2)
+md5sums=('95e53eb208c65ba6667fd4341455fa27')
+
+build() {
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ cd ${_basename}-${pkgver}
+ ./configure --prefix=/usr --sbindir=/usr/bin \
+ --build=i686-pc-linux-gnu --libdir=/usr/lib32
+ make
+}
+
+package() {
+ cd ${_basename}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ rm -r "${pkgdir}"/usr/bin
+ rm -r "${pkgdir}"/usr/include
+ rm -r "${pkgdir}"/usr/share
+}