summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMayorBender2020-08-16 10:27:42 -0400
committerMayorBender2020-08-16 10:27:42 -0400
commit08d821284800fa8561b67385d6c4bc30bbc54780 (patch)
treeaf2f561c3c400dedf0c0425121c2a19f383a6d42
downloadaur-08d821284800fa8561b67385d6c4bc30bbc54780.tar.gz
initial commit - v2.0.8
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..139e371eb678
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = lib50
+ pkgdesc = This is lib50, CS50's own internal library used in many of its tools.
+ pkgver = 2.0.8
+ pkgrel = 1
+ url = https://github.com/cs50/lib50
+ arch = any
+ groups = cs50
+ license = GPL
+ makedepends = python-setuptools
+ depends = python
+ depends = python-jellyfish
+ depends = python-attrs
+ source = https://files.pythonhosted.org/packages/source/l/lib50/lib50-2.0.8.tar.gz
+ sha256sums = 6d3a0bd46499446de14eedc8d948d152dd0e806e0c94a7ce51b8f496fffd6dab
+
+pkgname = lib50
+ depends = python
+ depends = python-jellyfish
+ depends = python-attrs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b363289569b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Generated using pip2pkgbuild - https://github.com/wenLiangcan/pip2pkgbuild
+# Maintainer: MayorBender <7480812+kingy9000@users.noreply.github.com>
+
+pkgname=lib50
+_module='lib50' # PyPI specific
+pkgver='2.0.8'
+pkgrel=1
+pkgdesc="This is lib50, CS50's own internal library used in many of its tools."
+url="https://github.com/cs50/lib50"
+depends=('python' 'python-jellyfish' 'python-attrs')
+makedepends=('python-setuptools')
+license=('GPL')
+arch=('any')
+groups=('cs50')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('6d3a0bd46499446de14eedc8d948d152dd0e806e0c94a7ce51b8f496fffd6dab')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}