summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordoragasu2023-04-23 10:01:37 +0200
committerdoragasu2023-04-23 10:01:37 +0200
commite803931cc4eadac8b18e29f0e0f4193d174d2576 (patch)
tree7856318b4d3fdc7821fadaded4cb96aa09fa0158
parent5230622ddc2da8bcb451124a246c5eaf7fb5286b (diff)
downloadaur-lib7zip.tar.gz
Fix makepkg not being able to checkout v17.04 p7zip
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 337460b08ed8..bd254fdb96c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib7zip
pkgdesc = A library using 7z.dll/7z.so(from 7-Zip) to handle different archive types.
pkgver = 3.0.0_17.04
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/stonewell/lib7zip
arch = i686
arch = x86_64
@@ -10,10 +10,10 @@ pkgbase = lib7zip
makedepends = libtool
options = !libtool
source = git+https://github.com/stonewell/lib7zip.git
- source = git+https://github.com/jinfeihan57/p7zip/#tag=v17.04
+ source = https://github.com/p7zip-project/p7zip/archive/refs/tags/v17.04.tar.gz
source = fix_build_errs.patch
sha256sums = SKIP
- sha256sums = SKIP
+ sha256sums = ea029a2e21d2d6ad0a156f6679bd66836204aa78148a4c5e498fe682e77127ef
sha256sums = 4c3f39beea4142283d76c2652d01ceaa647717d72359f75b9e7164082ba3a12d
pkgname = lib7zip
diff --git a/PKGBUILD b/PKGBUILD
index 80cd1586f760..b6f9f39591f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _commit=53abfeb6f1919fce3e65f21e37340153d2e4fe10
_ver=17.04
pkgname=lib7zip
pkgver=3.0.0_${_ver}
-pkgrel=2
+pkgrel=3
pkgdesc="A library using 7z.dll/7z.so(from 7-Zip) to handle different archive types."
arch=(i686 x86_64)
url="https://github.com/stonewell/lib7zip"
@@ -14,10 +14,10 @@ license=('MPL')
makedepends=('cmake' 'libtool')
options=('!libtool')
source=("git+https://github.com/stonewell/${pkgname}.git"
- "git+https://github.com/jinfeihan57/${_pkg}/#tag=v${_ver}"
+ "https://github.com/p7zip-project/${_pkg}/archive/refs/tags/v${_ver}.tar.gz"
"fix_build_errs.patch")
sha256sums=('SKIP'
- 'SKIP'
+ 'ea029a2e21d2d6ad0a156f6679bd66836204aa78148a4c5e498fe682e77127ef'
'4c3f39beea4142283d76c2652d01ceaa647717d72359f75b9e7164082ba3a12d')
prepare() {
@@ -26,7 +26,7 @@ prepare() {
patch -p1 < ../fix_build_errs.patch
# point to p7zip source
- export P7ZIP_SOURCE_DIR="${srcdir}/${_pkg}"
+ export P7ZIP_SOURCE_DIR="${srcdir}/${_pkg}-${_ver}"
cmake -DBUILD_SHARED_LIB=ON \
-DP7ZIP_SOURCE_DIR=${P7ZIP_SOURCE_DIR} \