summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordoragasu2020-04-28 17:31:18 +0200
committerdoragasu2020-04-28 17:31:18 +0200
commit115018bab295b829439877711282a6ec7a01664c (patch)
tree57de1fff0414aa67f6c303883835689e3dede786
parent8628433afd98ca7b7bff8ab7b5b03cfd2b923e0a (diff)
downloadaur-115018bab295b829439877711282a6ec7a01664c.tar.gz
Update to version 3.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD35
2 files changed, 20 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 084946fb3bbd..b4448ef40447 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib7zip
pkgdesc = A library using 7z.dll/7z.so(from 7-Zip) to handle different archive types.
- pkgver = 2.0.0
+ pkgver = 3.0.0
pkgrel = 1
url = https://github.com/stonewell/lib7zip
arch = i686
@@ -8,10 +8,10 @@ pkgbase = lib7zip
license = MPL
makedepends = libtool
options = !libtool
- source = https://github.com/stonewell/lib7zip/archive/5bc54cab38656fd57df7736087ef6914ddb68c72.tar.gz
- source = http://downloads.sourceforge.net/project/p7zip/p7zip/15.09/p7zip_15.09_src_all.tar.bz2
- sha256sums = 4ec0975a2bbdbdddd4a34517d8b0ea7026abbecd621d4f72744b754bba521308
- sha256sums = 8783acf747e210e00150f7311cc06c4cd8ecf7b0c27b4adf2194284cc49b4d6f
+ source = https://github.com/stonewell/lib7zip/archive/3.0.0.tar.gz
+ source = http://downloads.sourceforge.net/project/p7zip/p7zip/16.02/p7zip_16.02_src_all.tar.bz2
+ sha256sums = 75def3c6393ff4eb390ed5b82f89edc1b93fd1ac92680556a8d9a4e5cad7257c
+ sha256sums = 5eb20ac0e2944f6cb9c2d51dd6c4518941c185347d4089ea89087ffdd6e2341f
pkgname = lib7zip
diff --git a/PKGBUILD b/PKGBUILD
index 1c269b7679d5..8f385a8daf75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,10 @@
# Maintainer : doragasu <doragasu at hotmail dot com>
-# Contributor: Original submitter speps <speps at aur dot archlinux dot org>
+# Original submitter: speps <speps at aur dot archlinux dot org>
_pkg=p7zip
-_ver=15.09
-_commit=5bc54cab38656fd57df7736087ef6914ddb68c72
+_ver=16.02
pkgname=lib7zip
-pkgver=2.0.0
+pkgver=3.0.0
pkgrel=1
pkgdesc="A library using 7z.dll/7z.so(from 7-Zip) to handle different archive types."
arch=(i686 x86_64)
@@ -13,35 +12,31 @@ url="https://github.com/stonewell/lib7zip"
license=('MPL')
makedepends=('libtool')
options=('!libtool')
-source=("https://github.com/stonewell/${pkgname}/archive/${_commit}.tar.gz"
+source=("https://github.com/stonewell/${pkgname}/archive/${pkgver}.tar.gz"
"http://downloads.sourceforge.net/project/${_pkg}/${_pkg}/${_ver}/${_pkg}_${_ver}_src_all.tar.bz2")
-sha256sums=('4ec0975a2bbdbdddd4a34517d8b0ea7026abbecd621d4f72744b754bba521308'
- '8783acf747e210e00150f7311cc06c4cd8ecf7b0c27b4adf2194284cc49b4d6f')
+sha256sums=('75def3c6393ff4eb390ed5b82f89edc1b93fd1ac92680556a8d9a4e5cad7257c'
+ '5eb20ac0e2944f6cb9c2d51dd6c4518941c185347d4089ea89087ffdd6e2341f')
prepare() {
- cd "$srcdir/$pkgname-$_commit"
+ cd "$srcdir/$pkgname-$pkgver"
# point to p7zip source
export P7ZIP_SOURCE_DIR="$srcdir/${_pkg}_${_ver}"
- sh autogen.sh
- rm -rf includes/{C,CPP}
- ./configure --disable-dependency-tracking --prefix=/usr
+ cmake -DBUILD_SHARED_LIB=ON \
+ -DP7ZIP_SOURCE_DIR=${P7ZIP_SOURCE_DIR} \
+ -DCMAKE_BUILD_TYPE=RELEASE
}
build() {
- cd "$srcdir/$pkgname-$_commit"
+ cd "$srcdir/$pkgname-$pkgver"
make
}
package() {
- cd "$srcdir/$pkgname-$_commit"
- make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$pkgname-$pkgver/src"
- # Remove tests
- rm -rf $pkgdir/usr/bin
-
- # Add header
- install -Dm644 Lib7Zip/$pkgname.h \
- "$pkgdir/usr/include/$pkgname.h"
+ # Provided CMakeLists does not install files, so install manually
+ install -Dm755 $pkgname.so $pkgdir/usr/lib/${pkgname}.so
+ install -Dm644 $pkgname.h $pkgdir/usr/include/${pkgname}.h
}