summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Van Gestel2021-08-24 23:01:11 +0200
committerMatthias Van Gestel2021-08-24 23:01:11 +0200
commit9062c098c254578e57bf902e3dec57148191e735 (patch)
tree51920618b42c097ebcf6190a21192c4d6fab7016
parent92c73ed700b66b98612bf0e7e65da9fef7240743 (diff)
downloadaur-9062c098c254578e57bf902e3dec57148191e735.tar.gz
Correcting the PKGBUILD (thanks Fabio)
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
2 files changed, 17 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 286a8b86c67f..24b29ea1de35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,18 @@
pkgbase = lib_amxb-git
pkgdesc = Generic C-implementation for Ambiorix Backend library
- pkgver = v3.4.2.r0.gacf5fd3
+ pkgver = 3.4.3.r0.g81e9916
pkgrel = 1
url = https://gitlab.com/soft.at.home/ambiorix/libraries/libamxb.git
- arch = any
- license = MIT
+ arch = x86_64
+ arch = i686
+ arch = i486
+ arch = pentium4
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = BSD
+ makedepends = git
depends = lib_amxc
depends = lib_amxp
depends = lib_amxd
diff --git a/PKGBUILD b/PKGBUILD
index 2269a495f82b..5b32021683cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: fenrig <fenrig.linux at outlook.com>
pkgname=lib_amxb-git
-pkgver=v3.4.2.r0.gacf5fd3
+pkgver=3.4.3.r0.g81e9916
pkgrel=1
pkgdesc="Generic C-implementation for Ambiorix Backend library"
-arch=('any')
+arch=("x86_64" "i686" "i486" "pentium4" "arm" "armv6h" "armv7h" "aarch64")
url="https://gitlab.com/soft.at.home/ambiorix/libraries/libamxb.git"
-license=('MIT')
+license=(BSD)
depends=(
'lib_amxc'
@@ -14,6 +14,7 @@ depends=(
'uriparser'
)
makedepends=(
+ 'git'
)
provides=(
'lib_amxb'
@@ -29,7 +30,7 @@ md5sums=('SKIP')
pkgver() {
cd "${pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -40,4 +41,5 @@ build() {
package() {
cd "${pkgname}"
make DEST="${pkgdir}/" LIBDIR="/usr/lib" install
+ install -D LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}