summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Van Gestel2020-01-20 12:28:04 +0100
committerMatthias Van Gestel2020-01-20 12:28:04 +0100
commit595464ae1e66a1b3400291e9918736abe6e0a926 (patch)
treeac00230c9b5389a30ad24d2607a00b5d23686f3a
downloadaur-595464ae1e66a1b3400291e9918736abe6e0a926.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bbe4d1995ab5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = lib_amxc-git
+ pkgdesc = Generic C-implementation of data containers
+ pkgver = v0.1.1.r3.g128ff19
+ pkgrel = 1
+ url = https://gitlab.com/proj_amx_01/libraries/lib_amxc
+ arch = any
+ license = MIT
+ provides = lib_amxc
+ conflicts = lib_amxc
+ source = lib_amxc-git::git+https://gitlab.com/proj_amx_01/libraries/lib_amxc.git#branch=master
+ md5sums = SKIP
+
+pkgname = lib_amxc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9f3c512d0a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: fenrig <fenrig.linux at outlook.com>
+pkgname=lib_amxc-git
+pkgver=v0.1.1.r3.g128ff19
+pkgrel=1
+pkgdesc="Generic C-implementation of data containers"
+arch=('any')
+url="https://gitlab.com/proj_amx_01/libraries/lib_amxc"
+license=('MIT')
+
+depends=(
+)
+makedepends=(
+)
+provides=(
+ 'lib_amxc'
+)
+conflicts=(
+ 'lib_amxc'
+)
+
+gitbranch="master"
+
+source=("${pkgname}::git+https://gitlab.com/proj_amx_01/libraries/lib_amxc.git#branch=${gitbranch}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make DEST="${pkgdir}/" INSTALL_LIB_DIR="/lib" install
+}