summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Van Gestel2020-01-20 12:35:26 +0100
committerMatthias Van Gestel2020-01-20 12:35:26 +0100
commit8cf0242b56d3a8a9188a10cb9e65bf7bbc8126dc (patch)
treeea50fc10ef01e2fc41895d798ec1e4e61982d06c
downloadaur-8cf0242b56d3a8a9188a10cb9e65bf7bbc8126dc.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD40
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..600ea50ce41c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lib_amxm-git
+ pkgdesc = Generic C-implementation of modular support
+ pkgver = v0.0.0.r13.gb80f433
+ pkgrel = 1
+ url = https://gitlab.com/fenrig/lib_amxm
+ arch = any
+ license = MIT
+ depends = lib_amxc
+ provides = lib_amxm
+ conflicts = lib_amxm
+ source = lib_amxm-git::git+https://gitlab.com/fenrig/lib_amxm.git#branch=master
+ md5sums = SKIP
+
+pkgname = lib_amxm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9ac15ef731e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: fenrig <fenrig.linux at outlook.com>
+pkgname=lib_amxm-git
+pkgver=v0.0.0.r13.gb80f433
+pkgrel=1
+pkgdesc="Generic C-implementation of modular support"
+arch=('any')
+url="https://gitlab.com/fenrig/lib_amxm"
+license=('MIT')
+
+depends=(
+ 'lib_amxc'
+)
+makedepends=(
+)
+provides=(
+ 'lib_amxm'
+)
+conflicts=(
+ 'lib_amxm'
+)
+
+gitbranch="master"
+
+source=("${pkgname}::git+https://gitlab.com/fenrig/lib_amxm.git#branch=${gitbranch}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make DEST="${pkgdir}/" INSTALL_LIB_DIR="/lib" install
+}