summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Van Gestel2021-08-24 22:50:08 +0200
committerMatthias Van Gestel2021-08-24 22:50:08 +0200
commitcec47531c638ab897e4a1b9fd3d54ec64716fb59 (patch)
tree0a75a327b8470c02c208e09adbda83578d9cbdd8
parente9f6fdbddad70568610d0a9c05cea2f98d198ca3 (diff)
downloadaur-cec47531c638ab897e4a1b9fd3d54ec64716fb59.tar.gz
Correcting the PKGBUILD (thanks Fabio)
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
2 files changed, 17 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1506541208e..e62dab4dbc14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,18 @@
pkgbase = lib_amxm-git
pkgdesc = Generic C-implementation of modular support
- pkgver = v0.0.28.r0.gda18b41
+ pkgver = 0.0.29.r0.g5ea41d3
pkgrel = 1
url = https://gitlab.com/soft.at.home/ambiorix/libraries/libamxm
- arch = any
- license = MIT
+ arch = x86_64
+ arch = i686
+ arch = i486
+ arch = pentium4
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = BSD
+ makedepends = git
depends = lib_amxc
provides = lib_amxm
conflicts = lib_amxm
diff --git a/PKGBUILD b/PKGBUILD
index 7a8fd7ba8421..6c820042b009 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: fenrig <fenrig.linux at outlook.com>
pkgname=lib_amxm-git
-pkgver=v0.0.28.r0.gda18b41
+pkgver=0.0.29.r0.g5ea41d3
pkgrel=1
pkgdesc="Generic C-implementation of modular support"
-arch=('any')
+arch=("x86_64" "i686" "i486" "pentium4" "arm" "armv6h" "armv7h" "aarch64")
url="https://gitlab.com/soft.at.home/ambiorix/libraries/libamxm"
-license=('MIT')
+license=(BSD)
depends=(
'lib_amxc'
)
makedepends=(
+ 'git'
)
provides=(
'lib_amxm'
@@ -26,7 +27,7 @@ md5sums=('SKIP')
pkgver() {
cd "${pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -37,4 +38,5 @@ build() {
package() {
cd "${pkgname}"
make DEST="${pkgdir}/" LIBDIR="/usr/lib" install
+ install -D LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}