summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Van Gestel2021-08-24 23:07:38 +0200
committerMatthias Van Gestel2021-08-24 23:07:38 +0200
commit8ae32e62a6bfd350f18a4fdf2e2d870164745c07 (patch)
treef3ca5e865fe81250da0f9796dcf1ca5249c5b833
parentb15b24ed61fa277d3c0f1794ff93624e2d97e83f (diff)
downloadaur-8ae32e62a6bfd350f18a4fdf2e2d870164745c07.tar.gz
Correcting the PKGBUILD (thanks Fabio)
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD10
2 files changed, 17 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aab198dd6ac6..de932dcba4a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,18 @@
pkgbase = lib_amxo-git
pkgdesc = Generic C-implementation for ODL (Object Definition Language)
- pkgver = v1.3.3.r0.g6ae7bfb
+ pkgver = 1.3.4.r0.g925af0f
pkgrel = 1
url = https://gitlab.com/soft.at.home/ambiorix/libraries/libamxo.git
- arch = any
- license = MIT
+ arch = x86_64
+ arch = i686
+ arch = i486
+ arch = pentium4
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = BSD
+ makedepends = git
depends = lib_amxc
depends = lib_amxp
depends = lib_amxd
diff --git a/PKGBUILD b/PKGBUILD
index 3b6582f49a98..277283578a1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: fenrig <fenrig.linux at outlook.com>
pkgname=lib_amxo-git
-pkgver=v1.3.3.r0.g6ae7bfb
+pkgver=1.3.4.r0.g925af0f
pkgrel=1
pkgdesc="Generic C-implementation for ODL (Object Definition Language)"
-arch=('any')
+arch=("x86_64" "i686" "i486" "pentium4" "arm" "armv6h" "armv7h" "aarch64")
url="https://gitlab.com/soft.at.home/ambiorix/libraries/libamxo.git"
-license=('MIT')
+license=(BSD)
depends=(
'lib_amxc'
@@ -13,6 +13,7 @@ depends=(
'lib_amxd'
)
makedepends=(
+ 'git'
)
provides=(
'lib_amxo'
@@ -28,7 +29,7 @@ md5sums=('SKIP')
pkgver() {
cd "${pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -39,4 +40,5 @@ build() {
package() {
cd "${pkgname}"
make DEST="${pkgdir}/" LIBDIR="/usr/lib" install
+ install -D LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}