summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander 'z33ky' Hirsch2017-04-29 20:37:12 +0200
committerAlexander 'z33ky' Hirsch2017-04-29 20:37:12 +0200
commit4b29b66067fa36ea6e9189f200d78e4d1b250a6e (patch)
tree7e0a4f8121e8a153caa98fd36978dcb292a8c90b
parentcf18168b982d100d93a2a7b5568c6ac99567be7e (diff)
downloadaur-4b29b66067fa36ea6e9189f200d78e4d1b250a6e.tar.gz
Add python dep
Also do autoreconf in prepare().
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97d6ee4d63ce..39b9cb1f8a15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Apr 7 01:33:59 UTC 2016
+# Sat Apr 29 18:36:47 UTC 2017
pkgbase = libabigail-git
pkgdesc = ABI Generic Analysis and Instrumentation Library
- pkgver = 1.0.rc3.r17.gd06c4cd
+ pkgver = 1.0.rc6.r114.gc022243
pkgrel = 1
url = https://sourceware.org/libabigail/
arch = i686
@@ -10,6 +10,7 @@ pkgbase = libabigail-git
license = LGPL3
depends = libxml2
depends = elfutils
+ depends = python
source = libabigail::git://sourceware.org/git/libabigail.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4b1f3cc435e8..ea86238e8216 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
_pkgname=libabigail
pkgname="${_pkgname}-git"
-pkgver=1.0.rc3.r17.gd06c4cd
+pkgver=1.0.rc6.r114.gc022243
pkgrel=1
pkgdesc='ABI Generic Analysis and Instrumentation Library'
arch=('i686' 'x86_64')
license=('LGPL3')
url='https://sourceware.org/libabigail/'
-depends=('libxml2' 'elfutils')
+depends=('libxml2' 'elfutils' 'python')
source=("${_pkgname}::git://sourceware.org/git/libabigail.git")
sha256sums=('SKIP')
@@ -17,9 +17,13 @@ pkgver() {
git describe --long --tags | sed "s/^${_pkgname}-//;s/-/.r/;s/-/./g"
}
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ autoreconf -fi
+}
+
build() {
cd "${srcdir}/${_pkgname}"
- autoreconf -i
./configure --prefix=/usr --disable-static --disable-apidoc --disable-manual
make
}