summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre-Marie de Rodat2018-06-27 19:35:39 +0200
committerPierre-Marie de Rodat2018-06-27 19:35:39 +0200
commita8dfdfccf05a4f7d82fdf7abb96b45f767c818a0 (patch)
treeded6ed74874913ec5c25a9bc43e7fd2ccb7a5af0
parent8bd056bcb4d366344c0534f47080ee9ad08892b0 (diff)
downloadaur-a8dfdfccf05a4f7d82fdf7abb96b45f767c818a0.tar.gz
Use the setup.py script to install the Python binding
-rw-r--r--PKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b0e0a97883b0..34ae9163108b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -65,8 +65,6 @@ package()
install "$pkgdir/usr"
# Install the Python binding
- site_packages="$pkgdir/usr/lib/python2.7/site-packages"
- mkdir -p "$site_packages"
- install -m644 build/python/libadalang.py "$site_packages"
- rm -rf "$pkgdir/usr/python"
+ cd build/python
+ python2 setup.py install --root="$pkgdir"
}