summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlchristian Eckert2015-08-31 20:34:58 +0200
committerCarlchristian Eckert2015-08-31 20:34:58 +0200
commit4f7db7950b33fe6ad37628e49f7da0b474aabd2f (patch)
treeaeb627bdf8b0ae53caf48c799f0d8e19349ecbb9
parent1c572d897eb2afc7c6519dd17181bfebbded4095 (diff)
downloadaur-4f7db7950b33fe6ad37628e49f7da0b474aabd2f.tar.gz
excluding hdf5 from build
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 19b3de204545..3c6e407eea61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
pkgname=libadios
pkgver=1.9.0
-pkgrel=2
+pkgrel=3
pkgdesc="ADIOS Adaptable IO system for simulations. The Adaptable IO System (ADIOS) provides a simple, flexible way for scientists to describe the data in their code that may need to be written, read, or processed outside of the running simulation."
url="https://www.olcf.ornl.gov/center-projects/adios/"
install=$pkgname.install
license=('BSD')
arch=('i686' 'x86_64')
-depends=('netcdf' 'openmpi' 'python2' 'mxml')
+depends=('openmpi' 'python2' 'mxml')
source=(http://users.nccs.gov/~pnorbert/adios-$pkgver.tar.gz)
sha256sums=('f752b2093f5453b3ec4717aad67da7c3227b3687367a0b3fe7ad80eed391327e')
prepare() {
cd $srcdir/adios-$pkgver
- # replace all occurences of python with python2 to be explicit about the version
+ # replace all occurences of python with python2 to avoid using the default python3
find . -type f -print0 | xargs -0 sed -i -e 's/\(#\!\/usr\/bin\/env python\)/\12/' -e 's/python \(.*.py\)/python2 \1/'
}
@@ -24,8 +24,7 @@ build() {
CFLAGS="$CFLAGS -fPIC" ./configure --enable-static --enable-shared --prefix=/usr/ \
--with-mxml=/usr \
--with-mpi=/usr \
- --with-zlib=/usr \
- --with-hdf5=/usr
+ --with-zlib=/usr
make
}