summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlchristian Eckert2015-08-31 00:40:24 +0200
committerCarlchristian Eckert2015-08-31 00:40:24 +0200
commitb36c35c7cca0df398d166f3afd6d838a414c77a5 (patch)
treecd63b2f5d60281e97ef167c655d0af6daef457b1
downloadaur-b36c35c7cca0df398d166f3afd6d838a414c77a5.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
-rw-r--r--libadios.install8
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e225d06b20db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libadios
+ pkgdesc = ADIOS Adaptable IO system for simulations. The Adaptable IO System (ADIOS) provides a simple, flexible way for scientists to describe the data in their code that may need to be written, read, or processed outside of the running simulation.
+ pkgver = 1.9.0
+ pkgrel = 1
+ url = https://www.olcf.ornl.gov/center-projects/adios/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = netcdf
+ depends = openmpi
+ depends = python2
+ depends = mxml
+ source = http://users.nccs.gov/~pnorbert/adios-1.9.0.tar.gz
+ sha256sums = f752b2093f5453b3ec4717aad67da7c3227b3687367a0b3fe7ad80eed391327e
+
+pkgname = libadios
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..476ee8d70051
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Carlchristian Eckert <carli-eckert at gmx dot de>
+
+pkgname=libadios
+pkgver=1.9.0
+pkgrel=1
+pkgdesc="ADIOS Adaptable IO system for simulations. The Adaptable IO System (ADIOS) provides a simple, flexible way for scientists to describe the data in their code that may need to be written, read, or processed outside of the running simulation."
+url="https://www.olcf.ornl.gov/center-projects/adios/"
+license=('BSD')
+arch=('i686' 'x86_64')
+depends=('netcdf' 'openmpi' 'python2' 'mxml')
+source=(http://users.nccs.gov/~pnorbert/adios-$pkgver.tar.gz)
+sha256sums=('f752b2093f5453b3ec4717aad67da7c3227b3687367a0b3fe7ad80eed391327e')
+
+prepare() {
+ cd $srcdir/adios-$pkgver
+
+ # replace all occurences of python with python2 to be explicit about the version
+ find . -type f -print0 | xargs -0 sed -i -e 's/\(#\!\/usr\/bin\/env python\)/\12/' -e 's/python \(.*.py\)/python2 \1/'
+}
+
+build() {
+ cd $srcdir/adios-$pkgver
+ CFLAGS="$CFLAGS -fPIC" ./configure --enable-static --enable-shared --prefix=/usr/ \
+ --with-mxml=/usr \
+ --with-mpi=/usr \
+ --with-zlib=/usr \
+ --with-hdf5=/usr
+
+ make
+}
+
+check() {
+ cd $srcdir/adios-$pkgver
+ make check
+}
+
+package() {
+ cd $srcdir/adios-$pkgver
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/libadios.install b/libadios.install
new file mode 100644
index 000000000000..88d00ee07d35
--- /dev/null
+++ b/libadios.install
@@ -0,0 +1,8 @@
+post_install() {
+ post_upgrade
+}
+
+post_upgrade() {
+ echo "set the environment variable ADIOS_ROOT to be ADIOS_ROOT=/usr/ and the LD_LIBRARY_PATH to 'LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib'"
+}
+