summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Dewar2021-06-09 20:02:08 +0100
committerAlex Dewar2021-06-09 20:02:08 +0100
commit135d58f37ba02320b7d51c7ad5a99e1b87cdcc36 (patch)
tree8d9fa257bea671775ce57babdc344690436d2370
parentb22f552851d258184b69b1e5234fa4f4594890ed (diff)
downloadaur-135d58f37ba02320b7d51c7ad5a99e1b87cdcc36.tar.gz
Use version required by shortwave
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96b843fa2e8e..8897d7962347 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
-pkgbase = libadwaita-git
- pkgdesc = Library full of GTK widgets for mobile phones
- pkgver = r1560.4f6e828
- pkgrel = 2
+pkgbase = libadwaita-shortwave
+ pkgdesc = Library full of GTK widgets for mobile phones (version required by shortwave)
+ pkgver = r1937.afee036
+ pkgrel = 1
epoch = 1
url = https://gitlab.gnome.org/GNOME/libadwaita
arch = i686
@@ -9,7 +9,6 @@ pkgbase = libadwaita-git
arch = armv7h
arch = aarch64
license = LGPL
- checkdepends = xorg-server-xvfb
makedepends = git
makedepends = gobject-introspection
makedepends = meson
@@ -22,5 +21,4 @@ pkgbase = libadwaita-git
source = git+https://gitlab.gnome.org/GNOME/libadwaita
md5sums = SKIP
-pkgname = libadwaita-git
-
+pkgname = libadwaita-shortwave
diff --git a/PKGBUILD b/PKGBUILD
index b12db62b2fa0..515256951878 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+# Maintainer: Alex Dewar <alex.dewar@gmx.co.uk>
+# Contributor: Pellegrino Prevete <pellegrinoprevete@gmail.com>
# Contributor: Philip Goto <philip.goto@gmail.com>
# Contributor: Davide Depau <davide@depau.eu>
# Contributor: Rafael Fontenelle <rafaelff@gnome.org>
@@ -6,26 +7,25 @@
# Contributor: Bakasura <bakasura@protonmail.ch>
_pkgname=libadwaita
-pkgname=$_pkgname-git
-pkgver=r1560.4f6e828
-pkgrel=2
+pkgname=$_pkgname-shortwave
+pkgver=r1937.afee036
+_commit=9a52895fcd5a906791606400db1028fa0e527854
+pkgrel=1
epoch=1
-pkgdesc="Library full of GTK widgets for mobile phones"
+pkgdesc="Library full of GTK widgets for mobile phones (version required by shortwave)"
url="https://gitlab.gnome.org/GNOME/$_pkgname"
license=(LGPL)
arch=(i686 x86_64 armv7h aarch64)
depends=(gtk4)
makedepends=(git gobject-introspection meson sassc vala wayland-protocols)
-checkdepends=(xorg-server-xvfb)
source=("git+$url")
provides=($_pkgname)
conflicts=($_pkgname)
md5sums=(SKIP)
- pkgver() {
- cd $_pkgname
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- }
+prepare() {
+ git -C $_pkgname checkout $_commit
+}
build() {
arch-meson $_pkgname build -Dgtk_doc=false -Dexamples=true