summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12022-09-05 00:39:14 +0800
committerChocobo12022-09-05 00:41:21 +0800
commit74e380d87928e73af880a16f9b6e389bb32fe3b4 (patch)
tree52adf1a2ef376821372b1b78f95760a681de2b2f
downloadaur-74e380d87928e73af880a16f9b6e389bb32fe3b4.tar.gz
newpkg: libaio-git 0.3.113.r0.g1b18bfa-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4741864aeda
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libaio-git
+ pkgdesc = The Linux-native asynchronous I/O facility (aio) library
+ pkgver = 0.3.113.r0.g1b18bfa
+ pkgrel = 1
+ url = https://pagure.io/libaio
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = glibc
+ provides = libaio=0.3.113.r0.g1b18bfa
+ provides = libaio.so
+ conflicts = libaio
+ options = staticlibs
+ source = git+https://pagure.io/libaio.git
+ sha256sums = SKIP
+
+pkgname = libaio-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a90fe91214f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libaio-git
+pkgver=0.3.113.r0.g1b18bfa
+pkgrel=1
+pkgdesc="The Linux-native asynchronous I/O facility (aio) library"
+arch=('i686' 'x86_64')
+url="https://pagure.io/libaio"
+license=('LGPL')
+depends=('glibc')
+makedepends=('git')
+provides=("libaio=$pkgver" "libaio.so")
+conflicts=('libaio')
+options=('staticlibs')
+source=("git+https://pagure.io/libaio.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libaio"
+
+ git describe --long --tags | sed 's/^libaio.//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libaio"
+
+ make
+}
+
+check() {
+ cd "libaio"
+
+ #make partcheck
+}
+
+package() {
+ cd "libaio"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 {ChangeLog,README.md} -t "$pkgdir/usr/share/doc/libaio"
+ install -Dm644 man/*.3 -t "$pkgdir/usr/share/man/man3"
+}