summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikkel Kroman2015-06-30 16:59:47 +0200
committerMikkel Kroman2015-06-30 17:01:06 +0200
commite99eb7d65465c881366a2f241d4400cb87ab3a66 (patch)
tree4acb819934134dd087c5b09a29765f37542ea617
downloadaur-e99eb7d65465c881366a2f241d4400cb87ab3a66.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD35
-rw-r--r--glow-udev.rules8
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ddd1704ff3cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = antumbra-beta
+ pkgdesc = Cross-platform glow protocol library for the Antumbra. Includes antumbractl.
+ pkgver = 0.1.1.beta.r0.g09338d6
+ pkgrel = 1
+ url = https://github.com/TeamAntumbra/libantumbra
+ arch = x86_64
+ license = GPL3
+ makedepends = pkg-config
+ depends = libusb
+ source = antumbra-beta::git+https://github.com/TeamAntumbra/libantumbra.git#tag=0.1.1-beta
+ source = glow-udev.rules
+ sha256sums = SKIP
+ sha256sums = 58d51d2cf4b0df88dd6aa332fc5d63552ac1582af19d549cfcd30a3dcfe6389c
+
+pkgname = antumbra-beta
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a5ae1c8caaa4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+# Ignore generated package data.
+pkg/
+src/
+
+# Ignore the cloned repository.
+antumbra-beta/
+
+# Ignore downloaded archives and signatures.
+*.tar.xz
+*.tar.gz
+*.sig
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c417acb56a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Mikkel Kroman <mk@maero.dk>
+
+pkgname=antumbra-beta
+pkgver=0.1.1.beta.r0.g09338d6
+_pkgver=0.1.1
+pkgrel=1
+pkgdesc="Protocol library and tools for the Antumbra Glow"
+arch=('x86_64')
+url="https://github.com/TeamAntumbra/libantumbra"
+license=('GPL3')
+depends=('libusb')
+makedepends=('pkg-config')
+source=("${pkgname}::git+https://github.com/TeamAntumbra/libantumbra.git#tag=${_pkgver}-beta"
+ "glow-udev.rules")
+sha256sums=('SKIP'
+ '58d51d2cf4b0df88dd6aa332fc5d63552ac1582af19d549cfcd30a3dcfe6389c')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ make os=linux libantumbra.so
+ make os=linux antumbratool
+}
+
+package() {
+ install -Dm644 glow-udev.rules "${pkgdir}/usr/lib/udev/rules.d/40-antumbra-glow.rules"
+
+ cd "${srcdir}/${pkgname}"
+ install -Dm755 libantumbra.so "${pkgdir}/usr/lib/libantumbra.so"
+ install -Dm755 antumbratool "${pkgdir}/usr/bin/antumbratool"
+}
diff --git a/glow-udev.rules b/glow-udev.rules
new file mode 100644
index 000000000000..ee1fd993656b
--- /dev/null
+++ b/glow-udev.rules
@@ -0,0 +1,8 @@
+# udev rules for Glow. This makes Glow devices accessible to members of the
+# 'usb' group. Modify as necessary for your distro.
+
+# LUFA test VID/PID (alpha/unreleased firmware only)
+SUBSYSTEM=="usb", ATTRS{idVendor}=="03eb", ATTRS{idProduct}=="2040", TAG+="uaccess"
+
+# Production VID/PID via MCS Electronics (beta and later)
+SUBSYSTEM=="usb", ATTRS{idVendor}=="16d0", ATTRS{idProduct}=="0a85", TAG+="uaccess"