summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Hafner2017-02-12 23:54:31 +0100
committerSimon Hafner2017-02-12 23:54:31 +0100
commitd0d00c7edf3ca97344d0da1155d78e102df93892 (patch)
treebfaa1d285a55a8bfc7f5ae87439a2c190919963b
downloadaur-d0d00c7edf3ca97344d0da1155d78e102df93892.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD48
-rw-r--r--libao.conf2
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d96b1aa3712
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = libao-git
+ pkgdesc = Cross-platform audio output library and plugins
+ pkgver = 1.2.2.r2.1f998f5
+ pkgrel = 1
+ url = http://xiph.org/ao/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = libpulse
+ makedepends = git
+ depends = alsa-lib
+ provides = libao-pulse=1.2.2.r2.1f998f5-1
+ conflicts = libao-pulse
+ replaces = libao-pulse
+ backup = etc/libao.conf
+ source = git+https://github.com/xiph/libao.git
+ source = libao.conf
+ sha1sums = SKIP
+ sha1sums = 603f5e6715e7e50e1c8e8c1935c45a897c46e9af
+
+pkgname = libao-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d9dd4ba0ab7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Contributor: dorphell <dorphell@archlinux.org>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Maintainer: Simon Hafner <hanfersimon@gmail.com>
+
+pkgname=libao-git
+pkgver=1.2.2.r2.1f998f5
+pkgrel=1
+pkgdesc='Cross-platform audio output library and plugins'
+url='http://xiph.org/ao/'
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('alsa-lib')
+makedepends=('libpulse' 'git')
+backup=('etc/libao.conf')
+source=("git+https://github.com/xiph/libao.git"
+ 'libao.conf')
+sha1sums=('SKIP'
+ '603f5e6715e7e50e1c8e8c1935c45a897c46e9af')
+
+conflicts=('libao-pulse')
+provides=("libao-pulse=${pkgver}-${pkgrel}")
+replaces=('libao-pulse')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --enable-alsa-mmap
+
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 "${srcdir}"/libao.conf "${pkgdir}"/etc/libao.conf
+}
diff --git a/libao.conf b/libao.conf
new file mode 100644
index 000000000000..abddf7593d49
--- /dev/null
+++ b/libao.conf
@@ -0,0 +1,2 @@
+default_driver=alsa
+dev=default