summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-10-11 17:05:14 +0200
committerJ5lx2015-10-11 17:05:14 +0200
commitebd767da1fc000ec94431ebe36ac5f082c0705e8 (patch)
tree9398b07ec9d9796b8e304d46b84182c3fff9fa61
downloadaur-ebd767da1fc000ec94431ebe36ac5f082c0705e8.tar.gz
1.2.0-1: Initial package
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD52
-rw-r--r--libao.conf2
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ce8a488ac1c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = libao-jack
+ pkgdesc = Cross-platform audio output library and plugins - patched with JACK support
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = http://xiph.org/ao/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = libpulse
+ makedepends = jack
+ depends = alsa-lib
+ provides = libao=1.2.0-1
+ provides = libao-pulse=1.2.0-1
+ conflicts = libao
+ conflicts = libao-pulse
+ noextract = libao-jack-plugin.tgz
+ backup = etc/libao.conf
+ source = http://downloads.xiph.org/releases/ao/libao-1.2.0.tar.gz
+ source = https://trac.xiph.org/raw-attachment/ticket/2083/libao-jack-plugin.tgz
+ source = https://trac.xiph.org/raw-attachment/ticket/2083/0001-jack-plugin.patch
+ source = libao.conf
+ sha1sums = 6b1d2c6a2e388e3bb6ebea158d51afef18aacc56
+ sha1sums = 9e8436d5aa3c81496a8f315d75c4fba8ea24b3b6
+ sha1sums = 53af33fcf7a7981656ad5519cad38a0575c58afe
+ sha1sums = 603f5e6715e7e50e1c8e8c1935c45a897c46e9af
+
+pkgname = libao-jack
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..196f1bd188c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Contributor: dorphell <dorphell@archlinux.org>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+
+_pkgname=libao
+pkgname=${_pkgname}-jack
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Cross-platform audio output library and plugins - patched with JACK support"
+url="http://xiph.org/ao/"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('alsa-lib')
+makedepends=('libpulse' 'jack')
+backup=('etc/libao.conf')
+source=("http://downloads.xiph.org/releases/ao/${_pkgname}-${pkgver}.tar.gz"
+ "https://trac.xiph.org/raw-attachment/ticket/2083/libao-jack-plugin.tgz"
+ "https://trac.xiph.org/raw-attachment/ticket/2083/0001-jack-plugin.patch"
+ 'libao.conf')
+noextract=('libao-jack-plugin.tgz')
+sha1sums=('6b1d2c6a2e388e3bb6ebea158d51afef18aacc56'
+ '9e8436d5aa3c81496a8f315d75c4fba8ea24b3b6'
+ '53af33fcf7a7981656ad5519cad38a0575c58afe'
+ '603f5e6715e7e50e1c8e8c1935c45a897c46e9af')
+
+conflicts=('libao' 'libao-pulse')
+provides=("libao=${pkgver}-${pkgrel}" "libao-pulse=${pkgver}-${pkgrel}")
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ bsdtar -xf "${srcdir}/libao-jack-plugin.tgz"
+ patch -p1 -i "${srcdir}/0001-jack-plugin.patch"
+ autoreconf -if
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ ./configure \
+ --prefix=/usr \
+ --enable-alsa-mmap \
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 "${srcdir}/libao.conf" "${pkgdir}/etc/libao.conf"
+}
diff --git a/libao.conf b/libao.conf
new file mode 100644
index 000000000000..abddf7593d49
--- /dev/null
+++ b/libao.conf
@@ -0,0 +1,2 @@
+default_driver=alsa
+dev=default