summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhorsemanoffaith2016-02-06 20:08:36 -0800
committerhorsemanoffaith2016-02-06 20:08:36 -0800
commit2719dbfc32e15624616996bf351e668d09b90d69 (patch)
treee7ca190af647bbb4fff6351ff33f773fb0802974
downloadaur-2719dbfc32e15624616996bf351e668d09b90d69.tar.gz
Initial import
-rw-r--r--.SRCINFO42
-rw-r--r--0001-Glib.Timeout-fix.patch33
-rw-r--r--0002-Fix-mono-nunit-pkgconfig-name.patch25
-rw-r--r--0003-Fix-Mono-assemblies-directory.patch39
-rw-r--r--PKGBUILD83
5 files changed, 222 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce24c671f513
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+# Generated by mksrcinfo v8
+# Sun Feb 7 04:07:14 UTC 2016
+pkgbase = libappindicator-ubuntu
+ pkgdesc = A library to allow applications to export a menu into the Unity Menu bar
+ pkgver = 12.10.1.15.04.20141110
+ pkgrel = 2
+ epoch = 1
+ url = https://launchpad.net/libappindicator
+ arch = i686
+ arch = x86_64
+ groups = unity
+ license = LGPL
+ makedepends = dbus-glib
+ makedepends = libindicator-gtk2-ubuntu
+ makedepends = libindicator-gtk3-ubuntu
+ makedepends = libdbusmenu-gtk2-ubuntu
+ makedepends = libdbusmenu-gtk3-ubuntu
+ makedepends = gobject-introspection
+ makedepends = vala
+ makedepends = gtk-sharp-2
+ makedepends = pygtk
+ makedepends = perl-xml-libxml
+ makedepends = gtk-doc
+ source = https://launchpad.net/ubuntu/+archive/primary/+files/libappindicator_12.10.1+15.04.20141110.orig.tar.gz
+ source = 0001-Glib.Timeout-fix.patch
+ source = 0002-Fix-mono-nunit-pkgconfig-name.patch
+ source = 0003-Fix-Mono-assemblies-directory.patch
+ sha512sums = 328378d86fe81b6e154327ab53fb0d9ead4c2d7eae17f689966c381e65014bdaa91ec675857f6398c740560814346dd28a9de510f847facc9241efaccb2e33a6
+ sha512sums = e717a7e50ec4828bc4ea1701a4f707ddc695e16dfab2487c0e4f2f85ac50d2d215c99450e4191f0e29d402f0b28bf7b71d5cf2321d3b3b27b396a8bf8f3a393b
+ sha512sums = ea1822c3a09ef4c59d91b267d2ea0d0c9003c04ea0d8d4fb6a73e1b51084faccafbf41d6390a9c0e1326fd3334421539bdbb86a2a5e5022fa96e9d5196ef2d1d
+ sha512sums = 22e15f875a636bbbf8b1e80867a219b4b47b334d1bfe759f4ce79bf3665fc63af36b57fddb6c92aa7db148b5ea9ed789e510a9b23d87324b1b48695ad1ca9bc7
+
+pkgname = libappindicator-gtk2-ubuntu
+ pkgdesc = A library to allow applications to export a menu into the Unity Menu bar (GTK+ 2 library)
+ depends = libindicator-gtk2-ubuntu
+ depends = libdbusmenu-gtk2-ubuntu
+
+pkgname = libappindicator-gtk3-ubuntu
+ pkgdesc = A library to allow applications to export a menu into the Unity Menu bar (GTK+ 3 library)
+ depends = libindicator-gtk3-ubuntu
+ depends = libdbusmenu-gtk3-ubuntu
+
diff --git a/0001-Glib.Timeout-fix.patch b/0001-Glib.Timeout-fix.patch
new file mode 100644
index 000000000000..63247c686943
--- /dev/null
+++ b/0001-Glib.Timeout-fix.patch
@@ -0,0 +1,33 @@
+From f949448c898b2428e146d18e0821fa242a7099f6 Mon Sep 17 00:00:00 2001
+From: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+Date: Tue, 7 Oct 2014 17:21:42 -0400
+Subject: [PATCH 1/3] Glib.Timeout fix
+
+---
+ example/simple-client-vala.vala | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/example/simple-client-vala.vala b/example/simple-client-vala.vala
+index f8cd874..6d8d71b 100644
+--- a/example/simple-client-vala.vala
++++ b/example/simple-client-vala.vala
+@@ -20,6 +20,7 @@ You should have received a copy of the GNU General Public License along
+ with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
++using GLib;
+ using Gtk;
+ using AppIndicator;
+
+@@ -104,7 +105,7 @@ class SimpleClient {
+ print(@"Got scroll event! delta: $delta, direction: $direction\n");
+ });
+
+- Timeout.add_seconds(1, () => {
++ GLib.Timeout.add_seconds(1, () => {
+ percentage = (percentage + 1) % 100;
+ if (can_haz_label) {
+ ci.set_label(@"$(percentage+1)%", "");
+--
+2.1.2
+
diff --git a/0002-Fix-mono-nunit-pkgconfig-name.patch b/0002-Fix-mono-nunit-pkgconfig-name.patch
new file mode 100644
index 000000000000..0398698e3e6f
--- /dev/null
+++ b/0002-Fix-mono-nunit-pkgconfig-name.patch
@@ -0,0 +1,25 @@
+From 72de73f8d90fa54b884086dddf3b06a1d14b9e59 Mon Sep 17 00:00:00 2001
+From: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+Date: Tue, 7 Oct 2014 17:22:16 -0400
+Subject: [PATCH 2/3] Fix mono-nunit pkgconfig name
+
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index d131c9e..c8e480f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -160,7 +160,7 @@ AC_ARG_ENABLE([mono-test],
+ [enable_mono_test=auto])
+
+ if test x"$enable_mono_test" != x"no" ; then
+- PKG_CHECK_MODULES(NUNIT, nunit >= 2.4.7,
++ PKG_CHECK_MODULES(NUNIT, mono-nunit >= 2.4.7,
+ [have_nunit=yes],
+ [PKG_CHECK_MODULES(MONO_NUNIT, mono-nunit,
+ [have_nunit=yes],
+--
+2.1.2
+
diff --git a/0003-Fix-Mono-assemblies-directory.patch b/0003-Fix-Mono-assemblies-directory.patch
new file mode 100644
index 000000000000..42bfacc94ed1
--- /dev/null
+++ b/0003-Fix-Mono-assemblies-directory.patch
@@ -0,0 +1,39 @@
+From c31b285b856fdf4a131baab5e0a2397a375ac24f Mon Sep 17 00:00:00 2001
+From: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+Date: Tue, 7 Oct 2014 17:23:43 -0400
+Subject: [PATCH 3/3] Fix Mono assemblies directory
+
+---
+ bindings/mono/Makefile.am | 2 +-
+ bindings/mono/appindicator-sharp-0.1.pc.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/bindings/mono/Makefile.am b/bindings/mono/Makefile.am
+index 6f8e8a9..e1bd6e5 100644
+--- a/bindings/mono/Makefile.am
++++ b/bindings/mono/Makefile.am
+@@ -31,7 +31,7 @@ TARGET = \
+ $(DLLPOLICY1) \
+ $(POLICY1).config
+
+-assemblydir = $(libdir)/cli/appindicator-sharp-0.1
++assemblydir = $(libdir)/appindicator-sharp-0.1
+ assembly_DATA = $(TARGET)
+
+ CLEANFILES = \
+diff --git a/bindings/mono/appindicator-sharp-0.1.pc.in b/bindings/mono/appindicator-sharp-0.1.pc.in
+index f63c01e..ca09a6d 100644
+--- a/bindings/mono/appindicator-sharp-0.1.pc.in
++++ b/bindings/mono/appindicator-sharp-0.1.pc.in
+@@ -1,7 +1,7 @@
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
+ libdir=@libdir@
+-assemblies_dir=${prefix}/lib/cli/appindicator-sharp-0.1
++assemblies_dir=${prefix}/lib/appindicator-sharp-0.1
+
+ Name: appindicator-sharp
+ Description: application indicators for .NET
+--
+2.1.2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b04890ac018d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,83 @@
+# Maintainer: Michael Healy <horsemanoffaith@gmail.com>
+# Original Maintainer: György Balló <ballogy@freestart.hu>
+# Contributor: thn81 <root@scrat>
+
+# vercheck-pkgbuild: auto
+# vercheck-ubuntu: name=${pkgbase}, repo=xenial
+# vercheck-launchpad: name=${pkgbase}
+
+pkgbase=libappindicator-ubuntu
+pkgname=(libappindicator-gtk2-ubuntu libappindicator-gtk3-ubuntu)
+_actual_ver=12.10.1
+_extra_ver=+15.04.20141110
+pkgver=${_actual_ver}${_extra_ver/\+/.}
+pkgrel=2
+epoch=1
+pkgdesc="A library to allow applications to export a menu into the Unity Menu bar"
+arch=(i686 x86_64)
+url="https://launchpad.net/libappindicator"
+license=(LGPL)
+makedepends=(dbus-glib libindicator-gtk2-ubuntu libindicator-gtk3-ubuntu libdbusmenu-gtk2-ubuntu
+ libdbusmenu-gtk3-ubuntu gobject-introspection vala gtk-sharp-2 pygtk
+ perl-xml-libxml gtk-doc)
+groups=(unity)
+source=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname/\-*/}_${_actual_ver}${_extra_ver}.orig.tar.gz"
+ 0001-Glib.Timeout-fix.patch
+ 0002-Fix-mono-nunit-pkgconfig-name.patch
+ 0003-Fix-Mono-assemblies-directory.patch)
+sha512sums=('328378d86fe81b6e154327ab53fb0d9ead4c2d7eae17f689966c381e65014bdaa91ec675857f6398c740560814346dd28a9de510f847facc9241efaccb2e33a6'
+ 'e717a7e50ec4828bc4ea1701a4f707ddc695e16dfab2487c0e4f2f85ac50d2d215c99450e4191f0e29d402f0b28bf7b71d5cf2321d3b3b27b396a8bf8f3a393b'
+ 'ea1822c3a09ef4c59d91b267d2ea0d0c9003c04ea0d8d4fb6a73e1b51084faccafbf41d6390a9c0e1326fd3334421539bdbb86a2a5e5022fa96e9d5196ef2d1d'
+ '22e15f875a636bbbf8b1e80867a219b4b47b334d1bfe759f4ce79bf3665fc63af36b57fddb6c92aa7db148b5ea9ed789e510a9b23d87324b1b48695ad1ca9bc7')
+
+prepare() {
+ cd "${pkgbase/\-*/}-${_actual_ver}${_extra_ver}"
+
+ patch -p1 -i ../0001-Glib.Timeout-fix.patch
+ patch -p1 -i ../0002-Fix-mono-nunit-pkgconfig-name.patch
+ patch -p1 -i ../0003-Fix-Mono-assemblies-directory.patch
+}
+
+build() {
+ cd "${pkgbase/\-*/}-${_actual_ver}${_extra_ver}"
+
+ export CFLAGS+=" -Wno-error=deprecated-declarations"
+
+ export MCS=/usr/bin/mcs
+ export CSC=/usr/bin/mcs
+ export GMCS=/usr/bin/mcs
+
+ gtkdocize
+ autoreconf -vfi
+
+ [[ -d build-gtk2 ]] || mkdir build-gtk2
+ pushd build-gtk2
+ ../configure --prefix=/usr --with-gtk=2 --disable-static --disable-mono-test PYTHON=python2
+ make -j1
+ popd
+
+ [[ -d build-gtk3 ]] || mkdir build-gtk3
+ pushd build-gtk3
+ ../configure --prefix=/usr --with-gtk=3 --disable-static --disable-mono-test PYTHON=python2
+ make -j1
+ popd
+}
+
+package_libappindicator-gtk2-ubuntu() {
+ pkgdesc+=" (GTK+ 2 library)"
+ depends=(libindicator-gtk2-ubuntu libdbusmenu-gtk2-ubuntu)
+
+ cd "${pkgbase/\-*/}-${_actual_ver}${_extra_ver}/build-gtk2"
+
+ make -j1 DESTDIR="${pkgdir}/" install
+}
+
+package_libappindicator-gtk3-ubuntu() {
+ pkgdesc+=" (GTK+ 3 library)"
+ depends=(libindicator-gtk3-ubuntu libdbusmenu-gtk3-ubuntu)
+
+ cd "${pkgbase/\-*/}-${_actual_ver}${_extra_ver}/build-gtk3"
+
+ make -C src DESTDIR="${pkgdir}/" install
+ make -C bindings/vala DESTDIR="${pkgdir}/" install
+}